Support » Fixing WordPress » Avatar/Gravatar

  • I’m so frustrated because I cannot for the life of me figure this out! This is what I’m trying to do: I would like to change the default avatar to enable gravatar images. So that whenever I make a comment on my blog, my gravatar image appears beside my name and whenever someone else makes a comment, there gravatar image appears beside their name.

    However I can’t quite get it for some reason and its frustrating, can anyone explain to me how I can do this and if it is possible, I feel as though I’ve tried everything and nothing is working and I just don’t know..

    I’m trying to do this with two blogs of mine:

    http://MyBreality.com
    and
    http://FixaFlaw.com

    Thanks so much for any assistance with this!

Viewing 15 replies - 1 through 15 (of 17 total)
  • esmi

    (@esmi)

    Forum Moderator

    Start by enabling avatars in Settings->Reading. Then create your own gravatar account – using the same email address that you use on your blogs – at gravatar.com

    Settings >Reading?? Did you mean Settings>Discussion?

    I have avatars set to show, G, and Wavatar (Generated) for the default. Plus, I already have a Gravatar account with my picture uploaded already.

    I also tried to use the Gravatar for WordPress plugin (which is now currently deactivated) but all that did was input a wavatar image twice to the left of the commenters name and right beneath it.

    I’m terribly at a loss =(

    Can anyone perhaps refer me to someone or somewhere I can ask this?

    esmi

    (@esmi)

    Forum Moderator

    What version of WordPress are you using?

    I’m using a self-hosted wordpress blog and I have all available updates currently applied.

    esmi

    (@esmi)

    Forum Moderator

    So you’re running 3.0.4?

    Yes,sorry – that is correct =)

    esmi

    (@esmi)

    Forum Moderator

    Then you don’t need any kind of avatar plugin. Just ensure that your gravatar account is using the same email address as you used in WordPress and that your Settings->Discussion->Avatar configuration is correct.

    My Settings are set as Settings>Discussion>Avatar>Show Avatar>G>Wavatar

    What I don’t understand then is why all of my comments are shown as wavatars – I understand if the person leaving a comment is not signed up with a wordpress gravatar and thats why theirs is a wavatar – but mine is a wavatar too! Its not showing my picture beside my comments! Perhaps I should double check the email then, I don’t know what else to do – I’m not sure how to do that though. How can I doublecheck that my gravatar account email matches my wordpress email? Thank you so much!

    esmi

    (@esmi)

    Forum Moderator

    Login to your gravatar account and check.

    Ok but how do I compare my gravatar account then with my wordpress email? Lolz – sorry for my serious ignorance, I just want to figure this out but do it right. =P

    We see your gravatar here in this forum so check in your wordpress Settings General and see if you using the same email address as you using here and gravatar.com. You can always add another email address at gravatar.com

    Both my wordpress emails and my gravatar emails now match (I had to change my email in both of my blogs general settings). However, it still isn’t showing my gravatar – so it either takes quite awhile or its something else — Do you think it might be my blog themes?

    My one blog still shows wavatars and my other blog actually doesn’t show anything besides a name – wtf?! haha, here is link proof:

    http://www.mybreality.com/2010/11/23/to-attest-the-sands-of-time/

    http://fixaflaw.com/blog/568/skincare/things-to-know-about-natural-mole-removal/#comments

    (Just scroll down to the comments section so you can see what I mean, if it helps) =/

    Ahhhh I woke up this morning and checked them thinking that would have given them plenty of time to see my picture but its still the same thing!! I could perhaps grant someone admin access for a minute to help me out with this?? Both blogs still are not showing any gravatars – one doesn’t show anything (fixaflaw) and the other still shows wavatars (mybreality) – what the flip is going on?? I don’t get it =(

    esmi

    (@esmi)

    Forum Moderator

    Have you tried:

    – deactivating all plugins to see if this resolves the problem? If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the Twenty Ten theme to rule out any theme-specific problems?

    resetting the plugins folder by FTP or PhpMyAdmin? Sometimes, an apparently inactive plugin can still cause problems.

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘Avatar/Gravatar’ is closed to new replies.