Support » Plugin: Woocommerce Google Feed Manager » availability > backorder should be ‘in stock’

  • Resolved Bakkie

    (@eeuweb)


    I have products that i have in stock but also have the option for backorder. This way on the productpage it will show the most accurate delivery time.
    For google shopping i want to advertise for both product that are in stock and on backorder.

    unfortunately the way the feed works google will see backorder as ‘not in stock’ and will not alow advertising. Is there a option to change this?
    I know i could just change the feed setting availablillity to all in stock.. But this way i will also advertise for products that take a long time to get stock / never will be restocked.

Viewing 7 replies - 1 through 7 (of 7 total)
  • I think i already have managed to find the solution by changing availability to ‘in stock’ if stock status > does not include > out of stock..Hopefully this works.

    Plugin Author Auke Jongbloed

    (@aukejomm)

    Hello @eeuweb
    You did a prefect job with that.
    With the use of the condition editor you can do a lot with the data and this is a perfect example.

    You can open the feed your self and check if the condition you have created is correct and working.

    Let me know.

    Not yet, the feed does net seem to get updated correctly. I tried refreshing the caching plugin that is running (seen in in another topic here). The strange thing is that if I change the datafeed title and description > save and generate feed > open the xml feed file etc, the title and description is changed but not all product changes are in the feed. I tried adding some extra conditions but they are not added.

    I had this before on another website for a client. In the end I added a whole new feed to get it to work again. Still no clue what the reason is.

    • This reply was modified 1 month, 2 weeks ago by  Bakkie.

    Also just thought about the conditions I set up.. It will only return ‘In stock’ if it meets the conditions it set up.. Otherwise it wil return nothing.

    I am able to add a new condition line with OR > Stock status > includes > Out of stock.. But then i’m not able to set that the availability will be ‘out of stock’.
    Also added a new product and that one also is not added.

    Some more info
    – updated to newest version
    – less then 100 products in the feed (free version)

    • This reply was modified 1 month, 2 weeks ago by  Bakkie.
    Plugin Author Auke Jongbloed

    (@aukejomm)

    Hey @eeuweb,

    That is weird, have you tried creating a different feed and auto update the feed again to see if it is a weird anomaly?

    Could you show me the feed url and a screenshot from the stock settings with the condition!

    Feed update works again. Still not sure what solved it..maybe it is some other cache… Must be a logical explanation.. but what 😛

    Regarding the conditions. apparently I first had to delete the whole condition. After I added it again Another rule was added below.

    For people who want to setup in the same way:
    1 > Fill with static value > If [Stock Status] > Does not include > outofstock >> In stock
    2 > OR > Fill with static value > If [Stock Status] > includes > outofstock >> Out of stock

    If you want to advertise for products that you sometimes dont have on stock you should change in the product settings > Stock > Alow Backorders to Alow (and not Alow with informing customer).

    Plugin Author Auke Jongbloed

    (@aukejomm)

    Thanks for the update @eeuweb

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.