Support » Fixing WordPress » Autoupdate Plugins not working

  • Resolved dredfunk

    (@dredfunk)


    Hi,

    I just migrated to a new server running on FreeBSD 10.2 Everything works perfectly except updating plugins. Here’s what happens:

    1. Trying to update from Dashboard > Updates, I get:

    The update process is starting. This process may take a while on some hosts, so please be patient.

    Enabling Maintenance mode…

    Updating Plugin All In One SEO Pack (1/1)

    and nothing happens. The websites goes into maintenance mode and doesn’t work unless I delete the .maintenance file.

    2. Same thing happens when I try to update from Plugins > Installed Plugins > update now:
    It gets stuck at “Updating…”.

    Permissions are 100% ok. I checked the logs, no error shows up.

    I am running:
    FreeBSD 10.2
    php-fpm (PHP 7.0.3)
    nginx 1.8.1
    MySQL 5.7.10

    Any help would be appreciated.

    Thanks!

Viewing 6 replies - 1 through 6 (of 6 total)
  • Moderator t-p

    (@t-p)

    Have you considered installing plugins manually?: https://codex.wordpress.org/Managing_Plugins#Manual_Plugin_Installation

    FEMP WP failing plugin update is usually means missing package. Have you missed anything? We normally install these on FreeBSD :
    sudo pkg install nginx mysql56-server php56 php56-mysql
    then rehash
    sudo pkg install php56-xml php56-hash php56-gd php56-curl php56-tokenizer php56-zlib php56-zip
    Again rehash & restart the services. If vsftpd installed then check whether uploading enabled from settings.

    Hi Tara,

    Thanks for your reply. I would prefer using the auto update feature. I can fix stuff, just don’t know what’s going on. If anyone has any ideas where I should be looking for, please tell me.

    Moderator t-p

    (@t-p)

    It could be permission issue.

    Have you discussed this with your hosting provider?

    Also, try Enabling debugging and post the results.

    I managed to fix it. I wanted to install a new plugin and I got an error saying zlib extension was missing. I installed it, and now it works!

    Thanks.

    Moderator t-p

    (@t-p)

    glad to know it 🙂

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Autoupdate Plugins not working’ is closed to new replies.