Support » Plugin: Smush - Compress, Optimize and Lazy Load Images » AutoSmush not engaging in 2.5.3

  • Resolved barrd

    (@barrd)


    WCBRS 2019 Contributor

    Server Info: Apache/2.2.22 (Debian)
    PHP Version: 5.6.22-1~dotdeb+7.1

    The upgrade from 2.5.2 to 2.5.3 no longer has the manual button at point of adding an image to the library. The Automatic Smushing has not worked for a couple of versions now. This is a single site (i.e. not multisite) and the situation occurs in Grid and List view. In Grid view the text “Smushing in progress..” appears but nothing actually happens. In List view a button will appear after image upload prompting a manual Smush.

    Thank you again for an excellent plugin.
    Dave

    PS Auto smushing is conf’d to be “on” in settings 😉

    • This topic was modified 3 years, 1 month ago by barrd.
Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Support Nastia – WPMU DEV Support

    (@wpmudev-support9)

    Hello @barrd, I hope you are doing well!

    I am sorry to hear you have this issue.

    I tested the WP Smush 2.5.3 on my site and can’t replicate this issue. The Automatic Smushing is working on my site with the Grid and View list.

    Do you use any security plugins that may block connection with our servers? Would you please try to replicate the same issue with all the other plugins deactivated, leave the Smush plugin activated and upload an image.

    If the issue still persists, please enable WordPress debug mode. Add the lines bellow to the wp-config.php file:

    define( 'WP_DEBUG', true );
    define( 'WP_DEBUG_LOG', true );
    define( 'WP_DEBUG_DISPLAY', false );
    

    Try to reproduce the issue again and check the /wp-content/debug.log file for errors/warnings.

    Let us know how it went!

    Cheers,
    Nastia

    barrd

    (@barrd)

    WCBRS 2019 Contributor

    Hi Nastia,

    I am indeed doing well and thank you for your reply. 🙂

    I disabled all plugins except WP Smush 2.5.3 (same results), enabled debug mode, checked log and *ahem* found an issue with (an unrelated) deprecated call, however I fixed that, retested and the issue persists.

    System is now barebones and auto-smushing will not occur in either List or Grid views. I tried *many* scenarios, adding media from both pages and posts, then adding direct from the gallery — alas the same result occurs.

    Hope you too are well and again, thank you for your response.
    Dave

    Plugin Author Bojan Radonic – WPMU DEV Support

    (@wpmudev-support4)

    Hey Dave,

    Would you mind contacting us via contact form here so we can see if there’s something we can do to help: https://premium.wpmudev.org/contact/#i-have-a-different-question using this template:

    Subject: “Attn: Bojan”
    -link to your site
    -link back to this thread as reference
    -any other relevant urls

    Please use this subject line to ensure that it gets assigned to me 🙂

    Cheers,
    Bojan

    Plugin Author jdailey

    (@jdailey)

    Thank you for using WP Smush. I am going to mark this ticket resolved because it was moved to email. If we do not respond to your issue we can reopen this thread. Thanks again!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘AutoSmush not engaging in 2.5.3’ is closed to new replies.