Support » Requests and Feedback » Autosave broken in 5.6?

  • I see the Autosaving… message pop up in the top right-hand of wpadmin under WP 5.6. It had disappeared for several editions so good to see it back.

    But I go to close the edit and get the “Are you sure you want to leave this page” that normally accompanies trying to close without saving. If go ahead and close, the edit hasn’t (auto-)saved.

    Is autosave feature another broken in WordPress 5.6?

    Thanks
    MG

Viewing 4 replies - 1 through 4 (of 4 total)
  • Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    Nope, auto-saving is working fine, and has for several versions.

    If something on your site is blocking it, then you would need to find what error message you’re getting when the autosave occurs.

    I’m using Safari 14.0.2, so the message that pops up is “Are you sure you want to leave this page?” with two buttons below reading “Stay on Page” and “Leave Page”. These buttons normally appear in Safari if you’ve not finished filling a form and try to leave a page, for example.

    If I hit “Save Draft” in wpadmin, there’s no problem – the warning dialogue above doesn’t appear, the word “Saving” appears and when I close the post and reopen it, the saved version appears with the latest changes intact.

    It seems I can only save manually. Auto-save doesn’t save anything. When I started using WP about two years ago everything seemed to work fine.

    Now, as well as auto-save not working, Preview opens another tab but often hangs on “Generating preview” and never loads.

    In addition, in my case the more complicated Preview dropdown creates more work, impedes productivity; likewise the author dropdown, recently redesigned.

    I realise WP is free and appreciate its utility but I’m mystified by some recent “improvements” and wonder if anyone considered their practical implications.

    I’ve got a few “not resolved” topics open in this forum, and while some kindly responded very quickly, responses seem to have dried up quickly. Maybe I’ve exhausted my allocation of help. But then, yes, it’s free, so can’t complain, I suppose, and fair enough.

    I wonder if WP has developed a problem with Safari? Maybe Firefox or Chrome wouldn’t show the problems I describe above?

    Thanks
    Mark Gilbert

    Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    I’m using Safari 14.0.2, so the message that pops up is “Are you sure you want to leave this page?” with two buttons below reading “Stay on Page” and “Leave Page”.

    I don’t understand. Are you saying that that pops up when you take no action at all? Like, just wait a minute and then that happens when it tries to auto-save?

    You need to define the error that occurs when the autosave happens, not when you try to close the tab.

    This being a free forum populated by volunteers, and yes, since we can’t see what you see, then you may have to do some debugging on your own. We can’t help when the problem is ill-defined. I cannot use Safari, as I do not own any Apple products, for example.

    pressnine

    (@pressnine)

    Hello – thanks for picking up. Well, bizarrely, now the warning message isn’t appearing! Maybe some glitch or bad feature of Safari.

    However, this is what was happening:

    1) While editing or creating a post I saw the autosave activate in the top right of the admin window, where it normally says “Save Draft”.

    2) I thought great, it’s saved. So I hit “Posts” to leave the wp-admin/post page.

    3) On doing so, I got the message “Are you sure you want to leave this page?”

    4) If chose to leave the page, the changes weren’t saved.

    I’ll keep an eye out – I don’t trust it to always work and will continue as always to hit manual save every time I make a change.

    Intrigued to know if anyone else is getting the non-loading hang say 50% of the time when hitting Preview.

    Thanks again,
    MG

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.