• Resolved hbk123

    (@hbk123)


    Hi, I have a strange problem: because my Cache is growing very fast I´ve deactivated within Autoptimize the “Also aggregate inline JS” Checkbox (like recommended).

    But with this, my “WOOF-Products-Filter”-plugin on my Shop-page is no longer working: I can set the filters (e.g. price sorting), but nothing happends. My products were not sorted any more.

    After activating “Also aggregate inline JS” Checkbox inside Autoptimize again, WOOF works normally again.

    I already asked the plugin author of WOOF but he did not found the problem: https://pluginus.net/support/topic/autoptimze-s-aggregate-inline-js-leads-to-dysfunction-of-woof/#postid-7497

    The interesting thing is, that with disabling the Checkbox “Aggregate JS Files?” SWOOF works normally, even that with disabling this checkbox also the other checkbox is disabled too automatically.

    Do you have any ideas what the problem is and how it can be solved?

    thx in advance

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Optimizing Matters

    (@optimizingmatters)

    in that case you’ll also have to exclude the WOOF JS-files from being optimized hbk123

    hope this helps,
    frank

    Thread Starter hbk123

    (@hbk123)

    Dear Frank,

    thank you for your help. Unfortunately the result is strange:

    the author of SWOOF-plugin told me to exclude the file “front.js” from being optimized by Autoptimize. But this leads to the result, that the SWOOF-filter is not working (the skin of the SWOOF-filter in the sidebar changes and the products were not filtered).

    So the result is the same, like deactivating within Autoptimize the “Also aggregate inline JS” Checkbox. 

    It looks like SWOOF is not working without being optimzed by Autoptimize, this is strange, funny and sad at the same time 😉 Do you have any other idea?

    regards

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    Maybe try excluding plugins/woocommerce-products-filter/ instead?

    Thread Starter hbk123

    (@hbk123)

    OK, I think I found the problem: jquery.js was not excluded from being optimized. With excluding jquery.js from being optimized, SWOOF is working correctly if I deactivate within Autoptimize the “Also aggregate inline JS” Checkbox.

    I don´t know exactly the reasons, but now it works 🙂

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    that will be because the excluded SWOOF JS uses jQuery, good find hbk123 🙂

    Thread Starter hbk123

    (@hbk123)

    thanks
    (the only minus is, that excluding jquery.js from being optimized leads to Renedering-Blocking-comment in Google´s Page Speed Insight)

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    yeah, jQuery can be a pain .. :-/

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Autoptimze´s “Also aggregate inline JS” leads to dysfunction of WOOF-plugin’ is closed to new replies.