Support » Plugin: Autoptimize » autoptimize_single – Loading Twice – One with Version Appended

  • Resolved Jared

    (@jstecklercfanyorg)


    First of all, this is probably the single plugin that I find most valuable. The product is incredible, and you always provide top-notch support.

    I’m hoping you might be able to explain what could be going on here —

    Basically, it appears as if the script is being loading twice. One without the version string, and another with the version string. The one with the version string also is said to be a “MISS’ under cf-cache status.

    I assume whatever it is that I’m perceiving as an issue, has something to do with at least one of the factors listed below. And/or maybe it has something to do with HTTP/2.0 delivery that I don’t understand. But I’m wondering (1) Why the script looks like it’s being loaded twice; and (2) Why Cloudflare is failing to catch the file with the version number appended.

    GTMetrix Waterfall Chart Screenshot »

    Script is enqueued as such:

    elseif( is_single('51136') ) {
      wp_enqueue_style( 'dinner19-style', get_stylesheet_directory_uri() . '/dinner19-style.css', array( 'fusion-dynamic-css' ),'1.0.2' );

    dinner19-style.css is added under “Exclude CSS from Autoptimize” setting

    Any thoughts? The GTMetrix screenshot (linked above) should hopefully provide more context. Should I adjust the way I’m enqueuing the stylesheet in my functions.php? Should the exclusion rule in the Autoptimize setting include the version number of the stylesheet, like the way it is being enqueued? Is there actually nothing wrong to begin with?

    Let me know if there’s any additional information I can provide or clarify.

    Thank you again for all of your incredible work, man!

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘autoptimize_single – Loading Twice – One with Version Appended’ is closed to new replies.