Support » Plugin: Autoptimize » Autoptimize + Wp Super Cache + Elegant Themes Bloom

  • Resolved nemesis19

    (@nemesis19)


    Dear Developer,

    I want to report a strange behavior. I’m using the Bloom plugin from Elegant Themes and I put the “bloom” keyword both on JS and CSS blacklist in the Autoptimize settings.

    If WP Super Cache is off, everything works as expected and Autoptimize exclude the files correctly, but when instead I enable WP Super Cache it seems like it does something before Autoptimize (like with a higher priority) and Autoptimize minify everything without caring about the blacklist.

    With WP Super Cache enabled in fact I cannot see in the code the plugins I excluded from the Autoptimize settings.

    I tried to insert those “bloom” files in the WPSC advanced settings but without success.

    Is there something that you can done to have a “higher” priority before WPSC?

    Thanks, regards

    PS: anyway autoptimize is amazing, I’m using it already from many years, so thanks!

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Optimizing Matters

    (@optimizingmatters)

    that’s weird @nemesis19 … have you tried clearing WPSC’s cache?

    so many times…. 😅😅😅

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    obvious question, logical answer … 🙂

    can you share your URL + describe current config?

    sorry to bother, but after a further check I discovered that it’s totally a WP Super Cache fault.

    I’ve enabled right now just that plugin, keeping Autoptimize disabled and I can reproduce the issue of the Bloom plugin.

    http://www.epowerbike.it

    At the end of the page you can see a red part with the keyword “newsletter”, well under the text normally there should be an input field to put the email. That module is “bloom” as described in my very first post.

    I said “normally” because as you can see the input is not there. Don’t be baffled if you can see it at the beginning, navigate the different pages and scroll, or reload many times the page, it will disappear magically 😂.

    I forgot to mention that with just Autoptimize enabled, I don’t need to include bloom in blacklist. So again is totally a WPSP issue.

    I’m sorry for my mistake. If you have anyway a suggestion about how to exclude “bloom” plugin files. I already tried to add “/wp-content/plugins/bloom/*” to the WPSC exclusion strings in the advanced mode…no luck indeed.

    Well thanks anyway 🙂

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    interesting @nemesis19. just because I’m curious; where in WPSC’s configuration screens do you add those exclusions?

    Advanced tab and then scroll there is a text area with these default strings:

    wp-.*\.php
    index\.php

    I tried to add it without any good result…so it’s useless 😂😂😂

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    ow, but that field is to specify strings in the URL as seen by visitors that should not be cached? visitors see https://yourbl.og/2017/06/29 but never see https://yourbl.og/wp-content/plugins/bloom so that indeed cannot work. Now if you would have bloom in your URL for all pages that use that plugin, then you could exclude from page caching based on that string.

    exactly, I knew it could never work, but I tried…lost 1 minute of my life, it was worth it 😁

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Autoptimize + Wp Super Cache + Elegant Themes Bloom’ is closed to new replies.