Support » Plugin: Autoptimize » Autoptimize plugin – “invalid ‘in’ operand e

  • Resolved MKSnMKS

    (@mksnmks)


    I had just installed the MicroThemer Plugin, and it showed the following message for a js type file under Autoptimize;

    TypeError: invalid ‘in’ operand e (line 2)

    Q) How can this be corrected?

    Thanks

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Optimizing Matters

    (@optimizingmatters)

    Not enough info to give relevant feedback, can you share your URL @mksnmks ?

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    given lack of further info I’ll give some general feedback here;

    as a quick test you can disable AO on a per-request basis by adding ?ao_noptimize=1 to the URL.

    If your site works that way and no error is shown, then disable JS optimization for a second to see if that fixes it. If so, then you’ll probably have to add the plugin’s (or theme’s) JS to the comma-separated JS optimization exclusion list (and optionally untick the “minify excludes files” option). In that process you should keep an eye on your browser’s console for JS errors, as those will help you identify the problem.

    AO’s FAQ has more info on troubleshooting and how to exclude.

    hope this helps,
    frank (ao dev)

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Autoptimize plugin – “invalid ‘in’ operand e’ is closed to new replies.