Support » Plugin: Autoptimize » autoptimize performing poorly with sucuri cdn/firewall

  • Resolved wkeithgardner

    (@wkeithgardner)


    i had to disable autoptimize because of slow page loads (10s or more) by the sucuri firewall/cdn on godaddy. without autoptimize or non-cached url, the pages load in about 2s, whether the plugin is disabled or logged into the dashboard or bypassing the cdn. this is a recent problem. do you know what might be causing this problem?

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Optimizing Matters

    (@optimizingmatters)

    The only thing I can think of is cache misses on sucuri causing them to have to re-fetch the autoptimized CSS/ JS again. typically such cache misses would occur if you have CSS/ JS that changes, thereby causing AO to have to re-created the minified file with another hash. disabling “also aggregate inline JS” and “also aggregate inline CSS” generally helps in this case.

    What could help is doing a test (with and without AO enabled) on webpagetest.org (choose a location close to you and do 9 runs per test) so we can compare results?

    frank

    Thread Starter wkeithgardner

    (@wkeithgardner)

    inline js was already disabled. i disabled inline css and minify excluded files. this seems to have fixed the problem.

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    happy you were able to fix the problem wkeithgardner 🙂

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘autoptimize performing poorly with sucuri cdn/firewall’ is closed to new replies.