Support » Plugin: Autoptimize » Autoptimize makes images dissapear and conflicts with certain scripts

  • Resolved ap78

    (@ap78)


    Hi,

    Recently we started using Autoptimize to improve our page speed but we notice that at random occasions images start missing, for example on the homepage https://www.izaa.nl and scripts stop working, most importantly on this page where checking the upper, bold, checkbox is supposed to check ALL the checkboxes and scroll down the form. The scrolling is still working, but the check-all script isn’t.

    The mobile responsive menu in the theme also stopped working (worked around that by building a new UberMenu fueled menu).

    Tried a lot of solutions last week, including deactivating W3cache (didn’t help a bit). Any idea’s what to do now?

    Thanks in advance

    Peter

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Optimizing Matters

    (@optimizingmatters)

    Middag Peter;
    “check all” seems to work for me, but could be I’m lucky or that this is also a browser issue.

    One thing I do see though is this JS error on the browser console;

    
    ReferenceError: MD is not defined

    To fix that (and maybe your issue as well) try adding themes/marketers-delight/lib/assets/js/scripts.js to the comma-separated JS optimization exclusion list.

    If you still encounter the issue with the check-all checkbox, can you look at the console for JS errors and report back here?

    Groeten uit België,
    frank

    ap78

    (@ap78)

    Hi Frank,

    Laat ik het Engels houden voor eventuele meelezers met een zelfde probleem:

    I checked js in Chrome and Firefox and got this:

    chrome:

    (index):391 Uncaught ReferenceError: jQuery is not defined
    at (index):391
    autoptimize_8fde02077dba6e80710d9f03aa565337.js:2 JQMIGRATE: Migrate is installed, version 1.4.1

    firefox:

    Toetsgebeurtenis niet beschikbaar op sommige toetsenbordindelingen: key=‘i’ modifiers=‘accel,alt,shift’ id=‘key_browserToolbox’ browser.xul
    Unkown category for SetEventRecordingEnabled.
    (intermediate value).messages is undefined ASRouter.jsm:116

    _remoteLoader resource://activity-stream/lib/ASRouter.jsm:116 InterpretGeneratorResume self-hosted:1255 next self-hosted:1210

    1552985086828 app.normandy.recipe-runner ERROR Could not fetch recipes from https://normandy.cdn.mozilla.net/api/v1: “Error: recipe signature is not valid” Log.jsm:684

    append resource://gre/modules/Log.jsm:684 log resource://gre/modules/Log.jsm:365 error resource://gre/modules/Log.jsm:373 run resource://normandy/lib/RecipeRunner.jsm:215 throw self-hosted:1227

    Now to be honest I’m not much of a js expert, so I have no idea what I’m looking at. About 20 minutes ago the ‘check all’ options worked in Firefox (not in Chrome) but at the moment it stopped working in Firefox too (didn’t change anything though).

    Thanks again for replying, really appreciate it.

    • This reply was modified 5 months ago by  ap78.
    Plugin Author Optimizing Matters

    (@optimizingmatters)

    aha, jQuery is not defined, we (may) have a winner!

    I indeed see this in you HTML source;

    <script async type='text/javascript' src='https://www.izaa.nl/wp-includes/js/jquery/jquery.js'></script>

    Given the error-message above, you’ll have to exclude jquery from being asynced, can you do that and retest?

    frank

    ap78

    (@ap78)

    Yeah that definitely works, tested that before. Problem is, if we do that our Google page speed drops considerably. So I hoped to find what exact script to exclude. Guess there’s no solution?

    Peter

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    So I hoped to find what exact script to exclude.

    well, jquery.js 🙂

    Guess there’s no solution?

    There is, but is would require a developer changing the code of that page to wait until jQuery becomes available 🙂

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.