Support » Plugin: Autoptimize » Autoptimize is not combining

  • Resolved lhollowmanl

    (@lhollowmanl)


    I am using WP-Rocket with Stackpath CDN for my CSS and JAVASCRIPT files. I have tried to combine my Javascript files with Autoptimize in a single file but it is not doing it.

    Autoptimize is creating a file but it is empty and it does not combine my javascript. I’m also using Asyn javascript and this plugin does work wonders.

    I wanted to make tests and activate the option to combine javascript code from my html code and if it works but when I want to only activate the option to combine javascript urls it does not work.

    What could be the problem?

    Thank you very much for your reply.

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Optimizing Matters

    (@optimizingmatters)

    Can you try (or did you already?) adding the stackpath-url in AO’s CDN-setting? that way AO knows those are local files despite the different domain.

    If that doesn’t work you’ll have to disable “hide my wp” for a second to make sure the problem isn’t with that.

    frank

    lhollowmanl

    (@lhollowmanl)

    I had already added the url in the CDN Autoptimize configuration but it was not the problem. I followed his advice and apparently it already works when you disable the “hide my wp” plugin. You can enter my page and if it works, but how would you do to have the 2 activated?

    I am very surprised with your prompt response, no doubt you are a great support.

    Thank you!

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    how would you do to have the 2 activated?

    yeah, “hide my wp” changes URL’s, which breaks the mapping AO does between URL’s and the filesystem. if I’m not mistaking the author made some changes to enhance compatibility, but apperantly you still need some “glue” to make things work, see this blogpost for an example of what the “glue” can look like.

    I am very surprised with your prompt response, no doubt you are a great support. Thank you!

    you’re welcome, feel free to leave a review of the plugin and support here! 🙂

    and enjoy your sunday! 🙂

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Autoptimize is not combining’ is closed to new replies.