• Resolved joshgreg

    (@joshgreg)


    I installed and activated Product Filters for WooCommerce (by WooCommerce) but noticed that all product filters weren’t working. I deactivated all plugins and found that Autoptimize was the culprit.

    Here is a screenshot of Autoptimize deactivated – https://snipboard.io/O78LQ3.jpg

    Here is a screenshot of Autotimize activated – https://snipboard.io/ygVLRM.jpg

    From the screenshot which shows Autoptimize plugin deactivated, you’ll notice that the Price Slider isn’t showing up as is the case with other filters – nothing happens when clicked on.

    Following the solution proffered from your GitHub platform, I would prefer to exclude Product Filters for WooCommerce (by WooCommerce) from JS optimisation, but I have no clue about how to achieve this.

    • This topic was modified 3 years, 5 months ago by joshgreg.
Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Optimizing Matters

    (@optimizingmatters)

    Hi Josh;
    OK, let’s start with a quick test to make sure this indeed is a JS issue;
    * can you disable JS optimization and test if the filters do work?
    * can you check the browser console for errors when JS optimization is on and copy/paste those here?

    frank

    Thread Starter joshgreg

    (@joshgreg)

    Hello Frank,

    Thank you for getting back to me.

    So, I went ahead to disable JS optimisation and the filters seemed to be working as expected (here is a screenshot – https://snipboard.io/kO8Sj5.jpg); you’ll notice that the price slider filter loads fine. I then reenabled JS optimisation and checked my browser console for errors. I found that the console showed some errors (here is a screenshot – https://snipboard.io/oyCIzd.jpg). I’ve also pasted it here (below) as directed:

    JQMIGRATE: Migrate is installed, version 3.3.2
    autoptimize_f2ef39e61f666c4ef30209a65607f1de.js:215 Uncaught Error: Component prototype by entity key ‘Project’ not found
    at s.createComponent (autoptimize_f2ef39e61f666c4ef30209a65607f1de.js:215)
    at c.loadProject (autoptimize_f2ef39e61f666c4ef30209a65607f1de.js:215)
    at loadProject ((index):440)
    DevTools failed to load SourceMap: Could not load content for https://www.daisyparenting.com/wp-content/cache/autoptimize/maps/css/lifterlms.min.css.map: HTTP error: status code 410, net::ERR_HTTP_RESPONSE_CODE_FAILURE


    Josh

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    OK, can you try adding plugins/woocommerce-product-filters/ to the comma-separated JS optimization exclusion list?

    Thread Starter joshgreg

    (@joshgreg)

    I added the URL to comma-separated JS optimization exclusion list and it works fine now. Thank you for the assistance, Frank.

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    you’re welcome, feel free to leave a review of the plugin and support here! 🙂

    frank

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Autoptimize Incompatible with Product Filters for WooCommerce’ is closed to new replies.