Support » Plugin: Autoptimize » AutOptimize ‘generatepress_child/style.css’ not excluding ??

  • Resolved Paul Thomson

    (@pthomson87)


    Good afternoon team,

    I’ve got a bit of an odd one here… I’m using a child theme and I can’t figure out why ‘generatepress_child/style.css’ file is not being excluded from autoptimize when entered in exclude css settings and all other files I have in the settings are being excluded just fine.

    Is is potentially because of the priority at which it’s being called?

    to replicate the issue:

    add some custom css into generatepress_child/style.css file
    go to Autoptimize settings > CSS Options
    – Optimize CSS Code? : yes
    – Aggregate CSS-files? : yes
    – Also aggregate inline CSS? : no
    – Generate data: URIs for images? : no
    – Inline and Defer CSS? : yes
    – Inline all CSS? : no
    – Exclude CSS from Autoptimize: generatepress_child/style.css
    save changes and empty cache

    Notice how the generatepress_child/style.css file is still being caught in the aggregated autoptimize settings…

    Any idea?

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Optimizing Matters

    (@optimizingmatters)

    given I don’t have generatepress I cannot test a generate-press child-theme 😉

    can you share your site’s URL Paul?

    Paul Thomson

    (@pthomson87)

    Thanks for the quick response,

    Presumably, the issue might be the same for all child themes?

    Sure… http://Www.hearmeraw.uk

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    OK, the CSS is excluded, but given the fact it’s not minified (at least not based on filename) it became

    <link rel='stylesheet' id='generate-child-css' href='https://cdn.hearmeraw.uk/wp-content/cache/autoptimize/css/autoptimize_single_1546f41cefd8de449cc86060b91488d3.css' type='text/css' media='all' />

    if you untick the “minify excluded CSS/JS”-option this will not happen.

    hope this clarifies,
    frank

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.