Support » Plugin: Autoptimize » Autoptimize css is render blocking!!

Viewing 15 replies - 1 through 15 (of 16 total)
  • Plugin Author Frank Goossens

    (@futtta)

    not irony, but a conscious and deliberate choice gbengalex 🙂

    have a look at the FAQ for info on the “inline all CSS” and “inline & defer” options.

    gbengalex

    (@gbengalex)

    Ok tx. But I dont have any of the inline options enabled. ARe you saying that this is not render-blocking or that it is not a material impact?

    Plugin Author Frank Goossens

    (@futtta)

    I’m saying that inlining all CSS is easy and that it can -in certain circumstances- make the CSS non-render blocking. “inline & defer” is the better approach and if done right it always makes the CSS non-render blocking, but it is just not that easy.

    enjoy! 🙂

    gbengalex

    (@gbengalex)

    I have Autoptimize set to also aggregate JS in the HTML. But when I tested in google page speed and it is telling me the following are render-blocking:

    https://content.jwplatform.com/libraries/4r6XfcLg.js
    mysite/wp-includes/js/jquery/jquery.js
    mysite/…includes/js/jquery/jquery-migrate.min.js
    mysite/…-openid/includes/js/jquery.cookie.min.js
    mysite/…login-openid/includes/js/social_login.js

    Is there something else I should be doing?

    ALso I have it set to inline all CSS but google pagespeed is showing 15 css files need delivery optimized. (NOTE: when I check the option for Autoptimize to also aggregate CSS in the HTML it removed my background settings without any positive impact on the 15 css files).

    Thanks for any recommendations.

    Plugin Author Frank Goossens

    (@futtta)

    I’ll need your URL to see what is happening there gbengalex, no use in guessing our way out of this 🙂

    gbengalex

    (@gbengalex)

    akingbenga

    (@akingbenga)

    Hi. Were you able to discover anything?

    Plugin Author Frank Goossens

    (@futtta)

    sorry, must have missed this, will look into this later tonight 🙂

    Plugin Author Frank Goossens

    (@futtta)

    what do you have in the AO JS optimization exclusion-list gbengalex & akingbenga?

    akingbenga

    (@akingbenga)

    My apologies I dont even know what “AO JS optimization exclusion list” is

    Plugin Author Frank Goossens

    (@futtta)

    ah; on autoptimize’s configuration screen, after clicking “show advanced options”, you’ll see under “JS optimization” a form field with label “exclude JS from optimization”. so what’s filled in there?

    gbengalex

    (@gbengalex)

    Tx. I see the following in the form: seal.js, js/jquery/jquery.js

    gbengalex

    (@gbengalex)

    Tx. I see the following in the form: seal.js, js/jquery/jquery.js

    Plugin Author Frank Goossens

    (@futtta)

    in that case you there probably is another plugin telling autoptimize not to optimize things like

    mysite/…includes/js/jquery/jquery-migrate.min.js
    mysite/…-openid/includes/js/jquery.cookie.min.js
    mysite/…login-openid/includes/js/social_login.js

    you could try disabling/ re-enabling your plugins (and briefly switching themes) one at a time to find out which one is doing this if you want to get to the bottom of this?

    akingbenga

    (@akingbenga)

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Autoptimize css is render blocking!!’ is closed to new replies.