Support » Plugin: Autoptimize » Autoptimize crashes my website

  • Resolved baksteendegeweldige

    (@baksteendegeweldige)


    Hello,

    I have a strange issue with Autoptimize.
    If I include “/wp-includes/js/jquery/jquery.js” in the optimize ignore list,
    my website crashes every day at least once. (I monitor this with uptimerobot.com).

    I contacted my web hosting regarding this issue (because I first thought it was an issue with my webhost).
    This was there answer: (in dutch)

    “Ik heb hier nog wat verder naar gezocht. Jouw account is de “top” gebruiker op deze server en een tiental keer per dag worden er verbindingen van je account afgebroken omdat het aantal te hoog oploopt. Zie het voorbeeld hieronder waarbij er meer dan 100 verbinding quasi tegelijk starten en even later allemaal afgebroken worden doordat er hierbij excessief veel resources gebruikt worden. Dit is begonnen rond 26/10.”
    (In short: your account is the top recource user on the server, we have to cancel connections because the amount of connections exceeds the limit)

    If I disabled the Autoptimize plugin the problem was gone.
    I then further investigated this problem and noticed if I removed jquery.js from the ignore list the problem is solved. But some scripts on my website don’t work anymore. So I have to include jquery.js in the ignore list.
    At this moment Autoptimize is disabled on my website because of this problem.

    I know this is probably a conflict with another plugin or theme.
    But it is hard for me to investigate this because this is a live website, I can’t test/debug this a lot.

    If install Fast Velocity Minify instead of Autoptimize, the same problem occurs.

    Did you hear this problem before, do you have an idea which plugin causes this conflict?

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Optimizing Matters

    (@optimizingmatters)

    Hey Geweldige Baksteen 🙂

    I looked at your website and it’s … special; as you can see in this webpagetest.org test you’re loading 228 files, out of which 135 are JS and 55 are images.

    Now those 55 images are special, as most of them are loaded by JS and are loaded by Revolution slider (there are 4 JS files that are executed continuously; 2 revslider ones and 2 from your theme being lazysizes and the jQuery requestanimation frame one) see https://www.webpagetest.org/result/190325_8N_b85dab26e9f350b9d08a30bb5cc293bb/1/details/#waterfall_view_step1.

    The reason your site does not crash when you don’t exclude jQuery is that in that case the JS breaks, so the images aren’t loaded any more.

    My assumption; optimizing JS somehow makes the above situation worse (probably by a conflict between revslider & the Avada lazyload function).

    Some things to try/ consider:
    * If your theme can exclude images from being lazyloaded, then try exclude revslider images from being lazyloaded.
    * Or disable lazyloading
    * Or don’t put so many images in your slider
    * Or exclude revslider & your theme JS from being autoptimized
    * Or run AO including JS optimization but don’t aggregate files
    * Or run AO without JS optimization

    That being said; Raul is also right when he says you should consider better hosting 😉

    succes!
    frank

    Hello Frank, Thanks for your excellent and quick support 🙂
    Thanks for all the hints, I will try them.
    I will look for some better hosting.
    Bedankt!

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Autoptimize crashes my website’ is closed to new replies.