Support » Plugin: Autoptimize » Autoptimize cannot write to the cache directory

  • Hi,

    I am getting a “Autoptimize cannot write to the cache directory (default: /wp-content/cache/autoptimize), please fix to enable CSS/ JS optimization!” message at the top of the page. I saw there were other threads, but they didn’t help me.

    I am on CentOS and when I look at the owner it is ‘nobody’ and the current folder permission is set to 755. I changed it to 777 and also changed it to the account as the owner, but that didn’t change anything. Is there anything else I can try to fix this?

    I really like the plugin! Thanks.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Frank Goossens

    (@futtta)

    hard to say from afar @procyon, but as a general rule the user the webserver (php-process) is running under should have write-rights to wp-content/cache (and wp-content/cache/autoptimize and wp-content/cache/autoptimize/js and wp-content/cache/autoptimize/css but those get created if not there yet).

    hope this helps, somehow,
    frank

    Thx for the quick response. Is this somehow related to fastcgi? I recently switched to fastcgi from dso.

    • This reply was modified 3 years, 10 months ago by .
    Plugin Author Frank Goossens

    (@futtta)

    could be; the folder(s) should be writable for the user the fastcgi-php-process is running under.

    How can I check this?

    Plugin Author Frank Goossens

    (@futtta)

    that would depend on your fastcgi configuration really, but I’m afraid I don’t know anything about that :-/

    Hi, I am no expert, but are you running selinux in enforcing mode, selinux in enforcing mode does create this issue. Its good to setup the selinux policy if you know how to do it, or if you are not sure, disable selinux.

    Plugin Author Frank Goossens

    (@futtta)

    selinux in enforcing mode does create this issue.

    I didn’t know that, thanks for the info @rudrastays! 🙂

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Autoptimize cannot write to the cache directory’ is closed to new replies.