Support » Plugin: Autoptimize » Autoptimize 2.4 coming soon, need your help to test!

  • ResolvedPlugin Author Optimizing Matters

    (@optimizingmatters)


    Autoptimize 2.4 is coming in June/ July and the time has come to have it tested by as many people as possible!

    What’s new, you ask? Well;

    • it is based on a great fork by @zytzagoo with significantly improved code-quality and automated testing (travis-ci)
    • it features a new version of the CSS minifier which is _a lot_ faster and more reliable
    • it allows users to minify CSS/ JS without aggregating it
    • excluded CSS/ JS now gets minified
    • it “listens” to page caches getting purge to clear its own cache as well
    • better Google Fonts optimization (aggregated Google Fonts CSS gets preloaded)
    • image optimization (free during beta, will remain free up until a still to be specified threshold per domain)!

    How can you test, you ask? Well;

    1. download the AO 2.4 beta zipfile
    2. upload it as a new plugin
    3. deactivate the old 2.3.4
    4. and activate 2.4
    5. report any issues below as a Github issue

    And if you find no issues, maybe say so here in a reply. It’s always good to know if it just works as well 🙂

Viewing 15 replies - 31 through 45 (of 50 total)
  • I also upgraded to version 2.4.0-beta-4 and I am not seeing the “Aggregate JS-files” option. The Admin page looks the same as in beta-3.
    I deleted the plugin and re-uploaded it, but still no difference.

    In my installation of Autoptimize Version 2.4.0-beta-4,
    Aggregate JS-files? is the 2nd check box in JavaScript Options.

    The text associated with the check box says “Aggregate all linked JS-files to have them loaded non-render blocking? If this option is off, the individual JS-files will remain in place but will be minified.”

    I also note a new option in the Extra tab
    Optimize Images check box with the text;
    “Optimizes images using an image optimizing proxy.
    Free service provided by Shortpixel during Autoptimize 2.4 Beta cycle. After the official 2.4 release this will remain free up until a still to be defined threshold per domain, after which additional service can be purchased at Shortpixel. Usage of this feature is subject to Shortpixel’s Terms of Use and Privacy policy.”

    • This reply was modified 1 year, 5 months ago by AboutUtila. Reason: Added comment about Optimize Images in the Extra tab
    Plugin Author Optimizing Matters

    (@optimizingmatters)

    re (1); that’s correct, the wordpress.org version automatically “lives” in “autoptimize”, so you have to remove (or rename) the original version first.

    re (2); that’s know behavior (also in 2.3.x); the minification components used by AO leave “important” comments (starting with /*!, often contains copyright info) be. moreover, if AO finds a file with a filename that indicates it is minified (e.g. hooverer.min.js) then it will not re-minify that file, but simply aggregate it instead (minification is the most “costly” step).

    @aboututila I just discovered that I need to click on “Show advanced settings” to see the additional options.

    @franciscus
    My apologies for not noticing the Show/Hide advanced settings button in the top right corner of the Autoptimize Settings page (shown when the Main tab is selected).
    I guess I have always had that set to “Show advanced settings”.
    I’m glad you were able to solve the problem.

    @optimizingmatters
    Thank you for explaining why Autoptimize does not minify Javascript multi-line comments (comments that start with /* and end with */). I have had another look at the Javascript minified by Autoptimize and can see that these multi-line comments are indeed copyright notices.

    This may be useful to some people: I found that if I exclude adsbygoogle.js from JS optimization, the ads load a lot faster and don’t block the other javascript on the page.

    • This reply was modified 1 year, 5 months ago by franciscus.

    I wasn’t able to install it..

    I tried installing it first before deactiving the 2.3.4 version. It wasn’t working

    I then deactivated the old version and installed it..Not working neither.

    _______________________________
    Unpacking the package…

    Installing the plugin…

    Destination folder already exists. /home/howtol11/public_html/wp-content/plugins/autoptimize/

    Plugin installation failed.

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    if using the version from wordpress.org you’ll have to rename the original (2.3.4) autoptimize folder into something else (e.g. autoptimize_old) Tanya2018. you could try the github version instead, that installs into autoptimize-beta?

    Hi, I’m not sure if the following feature is going to fix the issue i have:

    “it “listens” to page caches getting purge to clear its own cache as well”

    I’ve reported before about how my theme (DIVI) clears the entire AO cache every time a post is published or even when the theme is updated using the following:

    		// Autoptimize
    		if ( is_callable( 'autoptimizeCache::clearall' ) ) {
    			autoptimizeCache::clearall();
    		}

    You’ve told me that this is unnecessary and i said how it’s creating lots of 404 errors.

    After speaking with support nothing seems to have been done about this, and i don’t know if or when something will happen.

    Is there any way for future versions of AO to control against such forced cache clearances? Or perhaps to ensure that the filenames don’t change when cache is cleared to avoid 404s? Thanks

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    afraid not Marty; autoptimizeCache::clearall is a publicly available function which is ment to be callable by whoever needs to clear AO’s cache. if a plugin misuses that there is nothing I can do I’m afraid :-/

    Autoptimize Version 2.4.0-beta-5 is installed.
    I noticed a minor CSS issue on my website which I didn’t notice before.
    I unchecked CSS Options -> Optimize CSS Code?
    The minor CSS issue did not occur.

    I used Web Developer -> Inspector to identify the potential ‘problem CSS file’.
    I suspect the problem CSS file is https://www.utilarealestateagent.com/wordpress/wp-content/themes/realhomes/assets/classic/scripts/vendors/flexslider/flexslider.css

    This is a CSS file associated with jQuery FlexSlider v2.6.
    I tried to exclude the flexslider.css from Autoptimize by adding it to
    CSS Options -> Exclude CSS from Autoptimize:
    I tried adding it as;
    (a) flexslider.css
    (b) flexslider/flexslider.css
    (c) realhomes/assets/classic/scripts/vendors/flexslider/flexslider.css
    (d) themes/realhomes/assets/classic/scripts/vendors/flexslider/flexslider.css
    but the flexslider CSS is always included in the autoptimize /wp-content/cache/autoptimize/css/autoptimize_single_XXXXXXXXXXXX.css file.

    I have no problem when excluding scripts from Autoptimize.

    Any idea what I may be doing wrong?
    Thank you.

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    thanks for the feedback @aboututila

    the flexslider CSS is always included in the autoptimize /wp-content/cache/autoptimize/css/autoptimize_single_XXXXXXXXXXXX.css file

    well, autoptimize_single_XXXXXXXXXXXX.css files are excluded files that were originally un-minified which AO keeps un-aggregated (as they’re excluded) but minifies. this will generally work OK as your post seems to confirm?

    Ignore what I said in my post.
    I now see what is happening.
    flexslider.css is being loaded as a separate file, but it is being minimized, so showing in Web Developer -> Inspector as a autoptimize_single_XXXXXXXXXXXX.css file rather than the original flexslider.css which is what is shown when I unchecked CSS Options -> Optimize CSS Code?

    My apologies for any confusion.

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    no issues aoubtutila, guess I’ll need to add this to the (updated) FAQ to explain 🙂

Viewing 15 replies - 31 through 45 (of 50 total)
  • The topic ‘Autoptimize 2.4 coming soon, need your help to test!’ is closed to new replies.