Support » Plugin: Autoptimize » Autoptimize 2.4.0 breaks client site

  • Resolved zoecorkhill

    (@zoecorkhill)


    I get the following errors in the php error log when the site is using the latest Autoptimize:

    [27-Sep-2018 12:57:25 UTC] PHP Warning:  require(/home4/***/public_html/wp-content/plugins/autoptimize/classes/autoptimizeCache.php): failed to open stream: No such file or directory in /home4/***/public_html/wp-content/plugins/autoptimize/autoptimize.php on line 71
    [27-Sep-2018 12:57:25 UTC] PHP Warning:  require(/home4/***/public_html/wp-content/plugins/autoptimize/classes/autoptimizeCache.php): failed to open stream: No such file or directory in /home4/***/public_html/wp-content/plugins/autoptimize/autoptimize.php on line 71
    [27-Sep-2018 12:57:25 UTC] PHP Fatal error:  require(): Failed opening required '/home4/***/public_html/wp-content/plugins/autoptimize/classes/autoptimizeCache.php' (include_path='.:/opt/php70/lib/php') in /home4/***/public_html/wp-content/plugins/autoptimize/autoptimize.php on line 71
    [27-Sep-2018 12:57:26 UTC] PHP Fatal error:  Allowed memory size of 536870912 bytes exhausted (tried to allocate 75497472 bytes) in /home4/***/public_html/wp-content/plugins/autoptimize/classes/external/php/yui-php-cssmin-bundled/Minifier.php on line 286
    [27-Sep-2018 12:57:26 UTC] PHP Fatal error:  Unknown: Cannot use output buffering in output buffering display handlers in Unknown on line 0

    The site will not load at all until the plugin is completely deleted. I tried upgrading the PHP version from 5.6 to 7.0 and increasing the memory limit via php.ini but it didn’t help. Once it had been upgraded to 7.0 I got this message when trying to load the site, whereas before it would either time out or end up with a database connection error:

    Fatal error: Unknown: Cannot use output buffering in output buffering display handlers in Unknown on line 0

    Deleted for now.

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Author Optimizing Matters

    (@optimizingmatters)

    this

    [27-Sep-2018 12:57:25 UTC] PHP Warning: require(/home4/***/public_html/wp-content/plugins/autoptimize/classes/autoptimizeCache.php): failed to open stream: No such file or directory in /home4/***/public_html/wp-content/plugins/autoptimize/autoptimize.php on line 71

    seems to point to a broken update/ installation of the plugin, as AO cannot function without classes/autoptimizeCache.php and that file is part of both the 2.3.4 and the new 2.4.0 version @zoecorkhill.

    so I would re-install (on a non-live site maybe to start with)?

    frank

    Thread Starter zoecorkhill

    (@zoecorkhill)

    Thanks, but I completely removed and reinstalled the plugin twice.

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    And if you (s)ftp into your server, is classes/autoptimizeCache.php file present or not?

    Thread Starter zoecorkhill

    (@zoecorkhill)

    Yes it was. Those errors may have been after I renamed the whole folder however, to try to get the site to load (it wouldn’t until I deleted as well as renaming).

    I think the errors that were preventing it from working when it was installed ‘fresh’ is this:

    [27-Sep-2018 12:57:24 UTC] PHP Fatal error:  Allowed memory size of 536870912 bytes exhausted (tried to allocate 75497472 bytes) in /home4/***/public_html/wp-content/plugins/autoptimize/classes/external/php/yui-php-cssmin-bundled/Minifier.php on line 286
    [27-Sep-2018 12:57:24 UTC] PHP Fatal error:  Unknown: Cannot use output buffering in output buffering display handlers in Unknown on line 0
    • This reply was modified 2 years, 7 months ago by zoecorkhill.
    • This reply was modified 2 years, 7 months ago by zoecorkhill.
    Plugin Author Optimizing Matters

    (@optimizingmatters)

    hmmm … the CSS minifier was indeed updated to a much newer version and as such it is not impossible that it behaves differently. could you confirm the problem is with CSS minification by re-enabling AO but disabling CSS optimization (so just HTML & JS active)?

    Thread Starter zoecorkhill

    (@zoecorkhill)

    That seemed to do the trick.

    Managed to go straight to settings and disable the CSS before the whole site crashed again, and so far it has stayed up.

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    OK, interesting!

    regarding CSS options (before the crash);
    * did you “also aggregate inline CSS”?
    * did you exclude CSS from optimization or did you just leave the default there (wp-content/cache/, wp-content/uploads/, admin-bar.min.css, dashicons.min.css)?
    * did you have “inline all” or “inline & defer” active?
    * could you share your customer’s site URL so I could have look at the (un-optimized) CSS?

    frank

    Thread Starter zoecorkhill

    (@zoecorkhill)

    The url is https://www.myrandommusings.co.uk

    * did you “also aggregate inline CSS”?
    Yes

    admin-bar.min.css and dashicons.min.css were both in the exclude list

    Inline and defer was on with the CriticalCSS analysis for her page a few months ago in there

    Looks like version issue.
    My server CPU was overload during the new version.
    After I saw CPU overload and website crashes.. I downgrade to my old version

    https://prnt.sc/kzfyg5

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    @uplinkk: can you confirm (as Zoe did) that disabling CSS optimization fixes this for you as well?

    @zoecorkhill;
    * I would love to work with you to get this working (I might indeed uncover a bug in AO that way), do you have a non-production site which we can test on? some things I would like to do include testing CSS optimization with the some CSS issues fixed (see below), disabling “also aggregate inline CSS”, excluding your main theme CSS, excluding your child theme CSS, … Goal being to pin down where exactly things go south.
    * there are 2 kind of biggish CSS issues on that site, see this screenshot of a CSS debugger I use;

    I am not certain this causes the CSS optimizer to break (which is what is happening), but fixing those can only make your site better 😉

    frank

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    @uplinkk @zoecorkhill; I’d love to help, but I would need your help to do so. do you have non-production sites where we could reproduce this behavior (which I can’t on my live sites or dev machines) and do some tests?

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    @zoecorkhill; 99,99% sure by now that the CSS syntax errors are the reason for the breakage.

    @uplinkk; With the help of someone who contacted me and who set up a test site for me to play around with, I identified an issue where AO when mbstring is not available uses iconv instead, which made the pages load slower. for this reason we will by default disable iconv as an alternative to mbstring (falling back on non-multibyte-safe functions). tests proved that this indeed makes the slowness go away. it is not inconceivable that this also is the cause of the CPU load increasing, so feel free to download the to-become 2.4.1 to test if this indeed fixes your resource usage as well?

    frank

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    closing as 2.4.1 with fix for CSS optimization has been released.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Autoptimize 2.4.0 breaks client site’ is closed to new replies.