WordPress.org

Support

Support » Plugins and Hacks » GrabPress » [Resolved] Autoposter doesn't work

[Resolved] Autoposter doesn't work

  • Each time I try to create a feed using the autoposter in Grabpress, and hit “create feed”, it just throws up a blank page. No matter what parameters I specify…same issue.
    This blank page also happens when I try to link my GrabMedia account with Grabpress. It just refuses to work.
    I’m using the latest version of the plugin, 2.3.7

    https://wordpress.org/plugins/grabpress/

Viewing 15 replies - 1 through 15 (of 16 total)
  • Plugin Author grabmedia

    @grabmedia

    We’re sorry to hear you’re having trouble creating a GrabPress feed. It sounds like the plugin is not connecting with the GrabPress backend service, Autoposter.

    Can you send us the domain (URL) associated with your GrabPress plugin so we can check to see if any errors were logged when the plugin tried to create a connector for your WordPress blog?

    If you don’t want to post your contact information online, you are welcome to email your blog information to us at support@grab-media.com. Please reference the link to this post if you contact us via email. Thank you.

    Hi
    The domain in question is zoombox.tv
    I can neither use the autoposter to create a feed, nor can I connect my Grab-Media account. Each time I try to do either of the above two actions, it just gives me a blank page.

    Plugin Author grabmedia

    @grabmedia

    We’re sorry to hear you’re having trouble with your feeds. We looked up your domain in our feed error logs, and we found your most recently created Autoposter connector (for GrabPress versions up to 2.3.7, the connector is created upon plugin installation).

    However, when I queried the feeds associated with your connector, there were no feeds. Additionally, I couldn’t find any errors associated with your connector ID.

    Question 1 – have you recently updated the WordPress users and permission levels in your WordPress admin? For GrabPress versions up to 2.3.7, you need to make sure the ‘grabpress’ user is in your WordPress Admin Users list, with Editor or Administrative rights. Also, the API key displayed on your Autoposter page (also in your WordPress MySQL DB) should match the password for the ‘grabpress’ user.

    Note: The ‘grabpress’ WP Admin user (added upon plugin activation) will be deprecated in our upcoming release, and replaced with WordPress REST API OAuth. The goals are to better integrate with the native WordPress platform/API and make the user better aware of the GrabPress authentication process.

    Question 2 – Have you checked your WordPress error logs? If there are any GrabPress specific errors found, please let us know.

    Let us know if that helps you track the issue down. We’re very interested to know what the issue is here.

    I am having the same issues on site musicjehad.com i had to uninstall and reinstall the plugin due to other issues, upon which the autoposter as indicated above just goes to a blank page and does not complete the process and now i cannot link to my grab media account. WordPress upgraded a 2 days ago..is there a conflict..well looks like the plugin autoposter and account linking issue on new instals is global..hope there is a fix. Please

    That is the key! It does not create feeds. It just shoots a blank page.
    The grabpress user account is there with editor rights. And yes, the password etc is the same as the API key. I did not change anything.
    The error logs mention nothing related to Grabpress.

    Hi, I wanted to add to this thread, I am also having the same issues. Can not link an account (even if you try and create a new one) and page goes blank after creating a feed. Seems to be after WordPress 3.8.2 update.

    I just tried test-running Grabpress plugin on a clean install, and I encountered the same issues.
    This is weird because 2-3 months back I was running Grabpress on wpfudge.com successfully without any issues. Is there some compatibility issue with the current version of WP?

    Plugin Author grabmedia

    @grabmedia

    GrabPress hasn’t been tested against WordPress 3.8.2 yet, as documented in our release notes. We’ve upgraded some of our QA instances to 3.8.2, but we have yet to verify the uninstall/install/upgrade process. We’ll update the thread once those test results are available.

    Hi Support,
    Thanks for the update. Should we revert our WP? Will this at least correct the issue until fully resolved by your end.

    I tried reverting to WP 3.8
    Same prob. Grabpress doesn’t work.

    Noted Joxocafeco, I tried as well and no luck. We will await Grabmedia support.

    Hi support, looks like you guys did something, all seems to be working now. Thank you for the support guys!!! All OK on my end.

    Plugin Author grabmedia

    @grabmedia

    @joxocafeco + @newsthrottle – We’re happy to confirm that this issue is resolved. It turns out the issue had nothing to do with WP 3.8 or the GrabPress plugin. It was an issue with a 3rd party API integration we use with the GrabPress backend service, Autoposter.

    Autoposter is the backend application that checks the metadata for videos that are continuously ingested to our video catalog, and posts them to each GrabPress feed with matchig search/metadata criteria.

    Basically, every time you register for an account, we use this 3rd party API to add each registered user (users who register for a GrabMedia account, not users who just install the plugin) to our Publisher CRM database. Our Publisher account managers then use that data to manage the payment and contact information each registered publisher account – this facilitates the process of getting publishers approved for ad campaigns and set up for being paid, as needed.

    The API key we were using for this functionality was broken for over a week, and it was completely out of our control. Now that we discovered the root cause of this issue, we made some improvements to the Autoposter backend service so that it’s no longer dependent on this 3rd party API integration – it now functions perfectly fine without this CRM API integration.

    Thank you guys!

    One half of the issues work: the Autoposter is working fine.
    I cannot, however, still link my Publisher account. It just does not log me in. The password and email details are correct.

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘[Resolved] Autoposter doesn't work’ is closed to new replies.
Skip to toolbar