Support » Plugin: WP RSS Multi Importer » AutoPost only works on Publish

  • Resolved rhellewell

    (@rhellewellgmailcom)



    Just installed your plugin (version 3.01) on the latest WP (a fresh install). Set up feed sources, and also set AutoPost on.

    If AutoPost is set to Publish, the items from the feed work (they show in the Posts, All Posts area, and also show up on the site).

    If AutoPost is set to “Draft”, then the feeds show up in the feed list, but don’t show in the Posts, All Posts area so that the Draft posts can be Published (or deleted, or edited, or whatever).

    Not sure what to do to fix this. Have spent quite a bit of time with various options, even cleared out the feed database and items and started over. But can only get AutoPost to work if I set it to Publish.

    Thanks for the help.

    …Rick..

    https://wordpress.org/plugins/wp-rss-multi-importer/

Viewing 7 replies - 1 through 7 (of 7 total)
  • Autopost is not working for me at all. Everything else is fine… Any thoughts please?

    Plugin Author Allen

    (@amweiss98)

    rhellewell – when the autopost is set to draft, all it does it take the post, add it as a WP blog post and set’s it’s status to draft. I’m not sure what the problem is..can you explain a bit more?

    wilfil – what do you mean it’s not working for you at all? Are you not seeing the feed items from the feed in the database? When you try to manually fetch the feeds for the AutoPost does nothing happen?

    rhellewell

    (@rhellewellgmailcom)

    If I set autopost to draft, I can see items in the Feed Items list. But those items are not shown in Posts, All Posts. I see no way to change a ‘draft’ post (in the Feed Items list) to Published.

    In fact, although there are items in the Feed Items list, and a Quick Edit of the Feed Item shows Published, the item doesn’t appear on the blog, and doesn’t appear on the Posts, All Posts screen.

    If I create a new Feed source via Add A Feed, and set the status of items to “Draft”, then activate that new Feed source, the plugin will grab the feed items. I can see the new items for that new feed source, and if I Quick Edit, the feed items are shown as Published. But these new items do not appear on the blog, and do not appear in the Posts, All Posts screen (which is set to display all types of posts).

    The only way I can get AutoPost to put items on the blog page are if I set Feed sources as “Publish”….which is not good, as I need to review/approve posts before they are published.

    Diagnostics run, report no errors.

    …Rick…

    Plugin Author Allen

    (@amweiss98)

    the way the plugin works is that the feeds go into the feed items database….if you want them to become blog posts, you need to then use the AutoPost feature…that pulls the items from the feed database and makes them blog posts.

    If you are already doing this, then give me admin access so I can see what’s going on.

    http://www.allenweiss.com/contact
    pw: gonecamping

    rhellewell

    (@rhellewellgmailcom)

    Allen: I am using AutoPost, as previously stated.
    Sent access to admin area of site via your contact form.

    Could you please post the solution here?

    I have the same problem – auto posts are set to “draft”, a lot of feed items are already in the database but are not saved as draft posts. When clicking on the “Click to fetch feed items now”-button on the bottom of …admin.php?page=wprssmi_options3 some of the feed items are saved as draft posts. But this doesn´t happen automatically.

    Also a text “Think there is a scheduling problem” is being displayed. Server cron is running (and working on other plugins). So I installed WP Crontrol to check all tasks but did´nt find any entry from RSS Multi Importer. Is this correct or should I find an entry there?

    I´m using version 3.0.1

    Best regards,
    Jan

    rhellewell

    (@rhellewellgmailcom)

    I believe the secret is to, on the Feeds List, then edit the feed, to click the green button (‘Fetch Feed Items Now’). That should get the actual feeds into the Posts, All Posts area.

    The section just below that green button on that page (‘Most Recent Items in the Database’) doesn’t really show a list of items that the plugin has gotten into the Post database. It just shows those items that it found on the feed source.

    If you use the green button (and perhaps the red button just before that to clear things out), you should be able to see the items in the Posts, All Posts page (after a short delay).

    …Rick…

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘AutoPost only works on Publish’ is closed to new replies.