Support » Plugin: Post to Google My Business » Autopost feature is no more working

  • I noticed it recently that GMB is no more posting content automatically from the website? I checked all settings and everything seems to be correctly configured.. Whats the issue?

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Contributor Koen Reus

    (@koen12344)

    Hi @ibioinformaticsindia,

    Are you sure the Google account is still properly connected? Maybe try reconnecting or refreshing the location list.

    Also check the Post to GMB metabox on the content that you expected to be published to GMB. Maybe there was an error creating the post (post will be highlighted in red).

    Thread Starter ibioinformaticsindia

    (@ibioinformaticsindia)

    No errors, and yes I turned on that button that appears in the right while posting something.

    Plugin Contributor Koen Reus

    (@koen12344)

    Does it create a new GMB post in the Post to GMB metabox though? Are you able to create a GMB post manually through the metabox?

    And do you use the classic editor or the block editor?

    Thread Starter ibioinformaticsindia

    (@ibioinformaticsindia)

    I’m using the block editor and if you can connect me on anydesk or similar and work it through that would be highly appreciated. I loved your plugin and used it for a very long time not happy to leave.

    Same here… I came here in hopes to find a solution.. I noticed my posts having been posing to google my business for about two months. I just realized.

    Plugin Contributor Koen Reus

    (@koen12344)

    Hi @xolde,

    Did you check the other things mentioned above?

    We tracked @ibioinformaticsindia’s problem down to the WP Cron system not working properly. The plugin uses it to publish GMB posts in the background so it does not slow down the site. If its not working, posts will not go out (or go out too late).

    You can check if everything is working through the WP Crontrol plugin (check for any errors and if there aren’t a lot of events that have missed their schedule).

    ~ Koen

    • This reply was modified 2 months, 1 week ago by Koen Reus.
    • This reply was modified 2 months, 1 week ago by Koen Reus.

    Ok. I will check.. I had noticed when i click on a post, the push to google button is turned off. When i try to turn it on, it goes on then back off on its own. Not sure if that has anything to do with it.

    Plugin Contributor Koen Reus

    (@koen12344)

    @xolde It automatically turns off after a GMB post has been created, otherwise it would create a new GMB post each time you edit/update the WordPress post (if you forget to turn off the checkbox).

    Plugin Contributor Koen Reus

    (@koen12344)

    @xolde @ibioinformaticsindia I’ve just released an update (2.2.45) that fixes an issue that also caused auto-post to fail. If you’re still experiencing this problem, you might want to try the update and see if that fixes it.

    ~ Koen

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.