WordPress.org

Forums

Featured Video Plus
autoplay/loop doesn't work with Vimeo video (6 posts)

  1. helloleanne
    Member
    Posted 1 year ago #

    Hi!

    I have a video hosted on Vimeo that I've embedded to my site using the Featured Video Plus plugin. It looks beautiful, and I love it, however I'd really like the video to autoplay and that function doesn't seem to be working specifically with this video. Autoplay works with a locally hosted video, but I'd really prefer to use the one hosted on Vimeo since I can control the look of the video better (I'm going for something like the intro video here: http://www.creativelive.com/ )

    Here's a link to the page on my site.
    http://leannemiller.com/home/

    Thanks so much! :)

    https://wordpress.org/plugins/featured-video-plus/

  2. Alexander Hoereth
    Member
    Plugin Author

    Posted 1 year ago #

    Autoplay with vimeo works for me.. Which video specifically? Some more details please.

  3. helloleanne
    Member
    Posted 1 year ago #

    Hey Alexander, thanks so much for getting back to me!

    I ended up going a different route on my homepage since I wasn't able to achieve what I wanted with the plugin. I just added the video to a test page so you can see what I mean: http://leannemiller.com/test-2/

    I love how the video fills my entire content div width when using the plugin, so I'd really appreciate any advice you could give. :) All the Media settings are set to autoplay, so I'm not sure where to go from here. Thank you!

  4. Alexander Hoereth
    Member
    Plugin Author

    Posted 1 year ago #

    And you didn't change anything in the plugins source? For example my plugin does not add a title to the iframe, further more the url in 1.9 has an hard coded http protocol (will change in 2.0).

    <!-- Featured Video Plus v1.9-->
    <div class="featured_video_plus responsive"><iframe src="//player.vimeo.com/video/89156970" width="560" height="205" frameborder="0" title="Morning Coffee: Website Intro" webkitallowfullscreen mozallowfullscreen allowfullscreen></iframe></div>
  5. helloleanne
    Member
    Posted 1 year ago #

    Those are options in Vimeo itself - that's how I removed the playbar, volume controls, etc. Those are things that I can control per video, so that whenever it is embedded it always has those settings. The option to autoplay, though, can only be added to the embed code and not set as an "always" setting. So, since the plugin generates the embed code, I can't go in and add the "autoplay" code myself. I asked about this on the Vimeo support forums, too... maybe this response will help:

    https://vimeo.com/forums/help/topic:115728

  6. losting
    Member
    Posted 8 months ago #

    helloleanne, your website header is exactly what I'm trying to do. Can you tell me if you ended up using Featured Video Plus for that effect. Its not working for me?

    Alexander Hoereth –
    I don't think my theme uses Featured Images, but I dropped in the shortcode
    [featured-video-plus]
    and it still isn't showing up.
    I tried it above 'Well Hello There' and 'Mike Schwab.' I can see those odd long grey boxes so I know its trying to do SOMETHING. Also, I'd prefer it be fullscreen, not boxed in the center but I think its a conflict with my theme.

    schwabeditorial.com
    The site hasn't launched yet...
    user: temp
    pass: temp

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Featured Video Plus
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.