Support » Plugin: YouTube Channel » Autoplay Playlist Not Working

  • Resolved knightgambit

    (@knightgambit)


    I recently added YTC to only my homepage (not my other pages since I have other YT videos playing on those throughout my site). Every time I reload the page the Random Video works but the Autoplay feature does not. (I noticed Random ONLY worked if User Controls were Enabled…weird glitch)

    Anyway, I was wondering how to get Autoplay to work with Random Video on reload. As well wondering if I can set the volume level instead of just Mute. Lastly is there a way to keep it from expanding on the page when clicking on the video.

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Contributor TechWebUX

    (@techwebux)

    Hello @knightgambit,

    I test YouTube Channel inserted as a widget on your homepage, and found all working as it should work:

    1. You have inserted youtube random video as a thumbnail. Once visitor click on the thumbnail, popup with autoplay YouTube video is shown.
    2. I configured widget on my demo website and changing User Controls visibility in the widget for thumbnail does not affect randomness – on reload in most cases different random video thumbnail is shown.
    3. Unfortunately, there is no option to set the initial volume on videos inserted with YouTube Channel plugin.

    If you would like to autoplay inline video directly in right-hand sidebar on page load, please change What to display? widget option from Thumbnail to HTML5 (iframe).

    Another detail I have noticed – you set cache timeout to 1 minute only. I would recommend updating widget option Cache feed to at least 1 hour.

    Kind regards,
    Aleksandar

    Thread Starter knightgambit

    (@knightgambit)

    Yes, that’s exactly what I’d like it to do. Autoplay on the sidebar only when the page reloads.

    I just set the widget to HTML 5 (iFrame) and set the Cache to 1 hr and it still doesn’t Autoplay. Random video from the Playlist does work though upon reload.

    Plugin Contributor TechWebUX

    (@techwebux)

    Hi @knightgambit

    Please let me know in which browser and on which device autoplay does not work for HTML5 (iframe) display mode so I can check?

    Here is a test in Chrome incognito on Windows – on each page reload video autoplay start https://drive.google.com/file/d/1B7n61O2LjA-qrPRhmMsqZ3OwkMOF7n39/view?usp=sharing

    Thank you for understanding,
    Aleksandar

    Thread Starter knightgambit

    (@knightgambit)

    So I tested the plugin on multiple browsers:

    Microsoft Edge – Works perfectly every time

    Google Chrome – Worked once, upon subsequent reload it doesn’t work at all now.

    Firefox – Never has worked (This is my default browser)

    This is what it looks like when you load a page but the autoplay doesn’t work:
    https://pasteboard.co/JHuL9Mh.jpg

    • This reply was modified 1 year, 7 months ago by knightgambit.
    Plugin Contributor TechWebUX

    (@techwebux)

    Hi @knightgambit,

    Newer versions of Firefox automatically block video and audio autoplay so you have to disable blocking of the autoplay in the browser. This is browser level restriction and cannot be overridden.
    Please check screenshot https://drive.google.com/file/d/1zbfEIFib4Y9vDZ7qn-bjuaMULCFXJPmO/view?usp=sharing

    Regarding Chrome, I managed to reproduce issue once in more than 10 page reloads. It could be related to Chrome blocking autoplay videos with sound, but I have to additionally investigate that in January. You could subscribe to the YouTube Channel project issue on GitHub https://github.com/urosevic/youtube-channel/issues/2 and track progress on this issue.

    You can try to use display mode “HTML5 (iframe)” instead of “HTML5 (iframe) Asynchronous” and see if that helps.

    Kind regards,
    Aleksandar

    Thread Starter knightgambit

    (@knightgambit)

    That was it! It was Firefox blocking it.

    Once I unblocked it, it started working perfectly. Will check back once the Chrome issue gets resolved.

    Really appreciate the plugin. Been looking for this for years.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Autoplay Playlist Not Working’ is closed to new replies.