Support » Plugin: Compact WP Audio Player » autoplay not working

  • bananacream

    (@bananacream)



    I’ve been having some trouble getting the autoplay function to do its thing. Here’s the shortcode I’m using:
    [sc_embed_player autoplay=true loops=”true” volume=”40″ fileurl=”http://ryanbridwellmusic.com/wp-content/uploads/2018/08/lost-in-a-dream-1.mp3|http://ryanbridwellmusic.com/wp-content/uploads/2018/08/lost-in-a-dream_2.ogg”]

    Without the autoplay snippet, the player works without any issue. I’m using Elementor with the Sydney theme. I’ve tried turning off all of my plugins and changing my theme to the default twentyseventeen, to no avail.
    Thank you!

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Contributor mbrsolution

    (@mbrsolution)

    Hi, which browser did you test? The reason why I am asking is because Google Chrome have made some changes to the autoplay function.

    Regards

    bananacream

    (@bananacream)

    Hi there, I tested firefox, chrome, safari and opera and all were a no-go with autoplay, but worked fine without the autoplay=true bit.

    Plugin Contributor mbrsolution

    (@mbrsolution)

    Okay lets try something. Add the the doublequotes to the parameter as such autoplay=”true”. Let me know how you go.

    bananacream

    (@bananacream)

    It didn’t work, unfortunately.

    Plugin Contributor mbrsolution

    (@mbrsolution)

    Okay lets try one more test. Can you now test an mp3 file instead of an ogg file with the autoplay=”true” parameter included?

    bananacream

    (@bananacream)

    Thank you! I had both the .mp3 and .ogg file linked and it’s working now on all the browsers I checked except for Safari, so we’re closer to the issue. I don’t understand why the original code worked on all browsers without the autoplay.

    Plugin Contributor mbrsolution

    (@mbrsolution)

    Can you share with me what is now working.

    Thank you

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.