Support » Plugin: Compact WP Audio Player » Autoplay not working

  • Hi,

    I am having an issue with your autoplay I am using the following shortcode:

    [sc_embed_player fileurl=”https://www.nottherealdomain.net/wp-content/uploads/2020/05/Descent.mp3″ autoplay=true]

    When I’m in Preview Mode on WordPress it will autoplay but as soon as it goes live nothing will play unless I click the Pause button then the Play button again. I have disabled all plugins (including cache plugins) and seem to be having no luck. The browsers I’m using is Chrome and Safari, could it be these browsers that are blocking it?

    Thanks in advance!

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Contributor mbrsolution

    (@mbrsolution)

    Hi,

    I tested the link added in the shortcode and it does not work. Also apparently your site is down. Also your shortcode is not properly coded. You need to enclose all parameters in double quotes as such "". Please see below.

    [sc_embed_player fileurl="https://www.nottherealdomain.net/wp-content/uploads/2020/05/Descent.mp3" autoplay="true"]

    Kind regards

    • This reply was modified 9 months, 2 weeks ago by mbrsolution.

    I cannot get the autoplay to work or the looping either. I have the correct syntax:

    [sc_embed_player fileurl=”https://notmysite.com/wp-content/uploads/2020/07/08-La-Grange-mp3.mp3″ autoplay=”true” loops=”true”]

    It looks like its trying to work – play button is on when I hit Preview Changes in WP, but it does not play. I have to hit the pause and play, then it plays. I have tried this on Firefox and Chrome. It only plays once if I hit the play manually. So the looping is not working either. I really want this song to play automatically when the site launches and continue playing as you visit other pages. Please help.

    Plugin Contributor mbrsolution

    (@mbrsolution)

    Hi, can you share your URL?

    Thank you

    [sc_embed_player fileurl=”https://doo-rags.com/wp-content/uploads/2020/07/08-La-Grange-mp3.mp3″ autoplay=”true” loops=”true”]

    By the way, your documentation does not include double quotes around the autoplay parameter – its a typo.

    It plays fine when you manually start it, but it will not auto start or loop.

    Plugin Contributor mbrsolution

    (@mbrsolution)

    Hi,

    The following URL does not work.

    https://doo-rags.com/wp-content/uploads/2020/07/08-La-Grange-mp3.mp3&#8243

    Why do you have &#8243 at the end?

    Kind regards

    • This reply was modified 8 months, 1 week ago by mbrsolution.
    • This reply was modified 8 months, 1 week ago by mbrsolution.
    • This reply was modified 8 months, 1 week ago by mbrsolution.

    I do not have those extra characters in the short code. They appeared in this post ONLY.

    There is nothing after 08-La-Grange-mp3.mp3 – no special characters. After the URL of the song, there is autoplay=”true” loops=”true”

    Its all correct, its just not working.

    Is it a browser limit? If so, why do you advertise it works for all major browsers?

    Plugin Contributor mbrsolution

    (@mbrsolution)

    Hi, I have submitted a message to the developers to reply to your question above.

    Thank you

    Thread Starter zvik

    (@zvik)

    I realised that to get the autoplay to work you cant go direct to the page via a URL. It will only work if you click a link/button which will direct you to the page. So it wouldn’t work for a home page

    Ok, I can test that. But I want the song to play while they are on the website. It stops as soon as I click to another page. Does your plugin play continuously no matter what page you are on? Is there any parameter to get it to play continuously, no matter what page you are on?

    No, it does not autoplay even on a secondary page. Show ma an example where this feature does actually work.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Autoplay not working’ is closed to new replies.