WordPress.org

Support

Support » How-To and Troubleshooting » autop problems

autop problems

  • alright, in my functions.php i have the following….

    <?php
    remove_filter(‘the_content’, ‘wpautop’);
    remove_filter(‘the_excerpt’, ‘wpautop’);
    remove_filter(‘comment_text’, ‘wpautop’);
    ?>
    <?php function mytheme_comment($comment, $args, $depth) {
    $GLOBALS[‘comment’] = $comment; ?>

  • <h5 class=”commentauthor”><?php comment_author(); ?></h5>
    <h6 class=”blogdateline”><?php comment_time(‘g:i:A’); ?> | <?php comment_date(‘F j, Y’); ?> </h6>
    <h6 class=”blogcontent”><?php comment_text(); ?></h6>

    <?php
    }

  • so as you can see i have disabled autop on the_content & comment_text. the rest of my functions.php is dedicated to restructuring how list_comments formats the comments. well it appears that autop is disabled on the_content and works fine for it, but wordpress is still putting paragraph tags around comments, and im not exactly sure why.

Viewing 1 replies (of 1 total)
  • dirty turtle

    @dirty-turtle

    you would think that if wordpress correctally recognizes the

    remove_filter(‘the_content’, ‘wpautop’); tag

    then it would also recognize the

    remove_filter(‘comment_text’, ‘wpautop’); tag

    but it doesnt. perhaps the other code in functions.php is messing with it somehow, but i cant seem to figure it out.

Viewing 1 replies (of 1 total)
  • The topic ‘autop problems’ is closed to new replies.
Skip to toolbar