Support » Plugin: Autoptimize » Autooptimize console error

  • Resolved yurchik1

    (@yurchik1)


    Hi,
    I’ve been using autoptimize for a while, but this error has never gone out of my console window: Uncaught TypeError: Cannot read properties of undefined (reading ‘indexOf’) (https://imgur.com/xOu4O8w)
    I’ve excluded jquery and jquery.min from optimizing by Autooptimize, but the issue still persists. What might I doing wrong?

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Optimizing Matters

    (@optimizingmatters)

    Hey yurchik1;
    I had a quick look (in FF), but don’t see that JS error on the homepage. Might this only happen for logged in administrators (or editors)? Maybe test with in an anonymous/ private browser window? Feel free to follow up here!

    best,
    frank

    Thread Starter yurchik1

    (@yurchik1)

    Thanks for your answer, @optimizingmatters !
    Yes, you’re right, the error is visible exclusively for logged in administrators. Also, I didn’t notice the message for those with simple “customer” roles.

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    in that case it’s pretty hard for me to see where the root cause is, but you could simply untick the “also optimize for logged in administrators/ editors” option (main AO settings page near the bottom) and be done with it? 🙂

    Thread Starter yurchik1

    (@yurchik1)

    Thank you so much @optimizingmatters !
    Now the issue is resolved and everything works better from the admin side!
    Was happy to contact you!

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    you’re welcome, feel free to leave a review of the plugin and support here! 🙂

    enjoy your sunday,
    frank

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.