Support » Plugin: Autoptimize » AutoOptimize changing the fonts on my site

  • Resolved gajvarma

    (@gajvarma)


    Hi,

    When I do disable Autoptimize, all fonts are shown correctly.

    This is how it looks when Autoptimize is disabled How it should look

    We can see that the font is ‘Raleway’ and it is 18px. It has overridden the previous CSS that has the font at 14px.

    This is what it looks like when I enable Autoptimize: After I enable Autoptimize

    The font is incorrect and not the right size.

    I saw some posts and that suggested to exclude the ‘styles.css’ file.

    This is what it looks like when I exclude ‘styles.css’ file:
    Autoptimized enabled and styles.css excluded

    We can see the font is “Source Sans Pro” and the font size is 14px instead of 18px.

    I currently have Autoptimized enabled so you can have a look.

    Thanks so much for your help.
    Gaj

    The page I need help with: [log in to see the link]

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Author Optimizing Matters

    (@optimizingmatters)

    First and foremost try to identify what is breaking things by just disabling CSS or JS or HTML or Image optimization (incl. lazyload). Based on that we can see what the next steps need to be šŸ™‚

    frank

    Thread Starter gajvarma

    (@gajvarma)

    Thanks for your quick reply Frank.

    I have enabled Autoptimize.

    Optimised Javascript Code, Optimise CSS Code and Optmise HTML code are all switched OFF.

    The site renders with the right format.

    If I turn on any of these options, it has the incorrect font. Even if I switch on ‘Optimise HTML Code’, it still fails.

    I tried to turn each of these on in isolation and it failed.

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    If I turn on any of these options, it has the incorrect font.

    that’s .. unexpected. do you have a staging-site where you could leave things in the wrong font for some time for me to look into?

    Thread Starter gajvarma

    (@gajvarma)

    Hi Frank, Yes that is unexpected. I’m not sure why optimizing the HTML would cause an issue as well.

    I don’t have a staging site.

    I have left the following options on the live site:

    Optimise Javascript Code – Ticked
    Aggregate JS-files – Ticked

    Optimize CSS Code – Ticked
    Aggregate CSS-files? – Ticked

    Optimise HTML Code – Ticked

    Having these options ticked is causing the incorrect font. You can see the right font in the link to the screen shot in my first post.

    I’m using the Sydney Theme.

    I’ll leave these as ticked for the next 12 hours. I can leave it a little longer if you need more time.

    Thanks for your help.

    Thread Starter gajvarma

    (@gajvarma)

    Also the ‘Exclude CSS from Autoptimize’ has the following contents:

    wp-content/cache/, wp-content/uploads/, admin-bar.min.css, dashicons.min.css

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    what is “also aggregate inline CSS” set to?

    Thread Starter gajvarma

    (@gajvarma)

    ‘Also aggregate inline CSS?’ is set to UNTICKED.

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    OK, can you enable that and (for now) remove wp-content/uploads from the CSS optimization exclusions?

    Thread Starter gajvarma

    (@gajvarma)

    No problems, I have done that.

    Thanks.

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    It looks like the linked Google Font stylesheet is missing in action, what is your Google Font setting on Settings -> Autoptimize -> Extra?

    Thread Starter gajvarma

    (@gajvarma)

    Hi,

    This is exactly what the problem was. The ‘Remove Google Fonts’ option was ticked.

    If I change it to one of the other options, it works fine. I’ve currently set it to ‘Combine and link deferred in head’ and it works fine.

    If you have any other suggestions, please let me know.

    Thanks so much for helping me with this. I really appreciate it.

    Gaj

    Thread Starter gajvarma

    (@gajvarma)

    This is resolved.

    Thank you so much for your help.

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    you’re welcome, feel free to leave a review of the plugin and support here! šŸ™‚

Viewing 13 replies - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.