Support » Plugin: Autoptimize » Autooptimize Breaks bbPress Text Editor

  • Resolved pyoil

    (@pyoil)


    Here is an example page – https://ofpad.com/topic/test/

    Autooptimize breaks bbPress text editor.

    https://i.imgur.com/gmrKECj.png

    When I disable Autooptimize the text editor works.

    https://i.imgur.com/PZVQ3z8.png

    I had the same problem with the Visual Editor but I managed to fix it by adding wp-includes/js/tinymce to the exclude list.

    You might need to login as a subscriber to test the feature. Here is a sample credentials:
    Username: tester
    Password: tester1234

    • This topic was modified 1 year, 2 months ago by pyoil.
    • This topic was modified 1 year, 2 months ago by pyoil.

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Optimizing Matters

    (@optimizingmatters)

    well for starters, you’re asyncing jQuery and that causes “jQuery is not defined” errors. you also might have to exclude backbone & underscore from JS optimization.

    hope this helps,
    frank

    I added the following to the exception and it is working now

    wp-includes/js/tinymce, js/backbone.min.js, js/underscore.min.js, js/comment-reply.min.js

    I added the above here.

    Settings > Autooptimize > JavaScript Options > Exclude scripts from Autoptimize:

    • This reply was modified 1 year, 2 months ago by pyoil.
    • This reply was modified 1 year, 2 months ago by pyoil.
    • This reply was modified 1 year, 2 months ago by pyoil.
    Plugin Author Optimizing Matters

    (@optimizingmatters)

    Good job pyoil! 🙂

    Hope it helps others

    • This reply was modified 1 year, 2 months ago by pyoil.

    Thanks ! Thanks ! Thanks !

    I had an error with another plugin and you solved my problem ! 😀

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Autooptimize Breaks bbPress Text Editor’ is closed to new replies.