Support » Plugin: XCloner - Backup and Restore » Automatically Upload to Remote Storage

  • Hi,

    I have Google Drive setup on xCloner and I would like it so that after a manual/scheduled backup is created locally, it would then be uploaded to Google Drive automatically, and then be deleted locally.

    How would I be able to do that?

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Liuta Ovidiu

    (@xcloner)

    You simply need to create a scheduled backup and select Google Drive as target remote storage. For deletion, please check the option “Delete Backup After Remote Storage Transfer” from XCloner Settings->Cleanup Tab

    Hope it helps.

    After testing the upload for a few days, things look pretty good so far. Is there a way to limit the amount of backups stored on Google Drive? For example, if I only want 10 backups maximum, any new backup will delete the oldest of the 10.

    Plugin Author Liuta Ovidiu

    (@xcloner)

    In the Google Drive Remote Storage option you have the option to cleanup the remote storage after a specified number of days as well as automatically empty it’s trash

    Let me know if you have further issues.

    Thanks, I noticed that, but what if I set the specified number of days to 10 days, but the backups failed for whatever reason and I don’t check on the site for 2 weeks or something. Wouldn’t that mean all the backups would be deleted?

    Plugin Author Liuta Ovidiu

    (@xcloner)

    Yes, that could happen, but it depends on the failure, if it’s an exception, then the backup might not finish the process so it would not get to the cleanup point. You usually get an email with a notification message containing the failed reason message.

    That might present a problem if it ‘could’ happen. If by some chance it somehow gets to the cleanup point and starts deleting backups without replacing them and I wasn’t able to get emails for whatever reason (vacation, email change, mail server problems, etc).

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.