Support » Fixing WordPress » Automatic WP Update via SSH not working

  • I have updating via SSH configured via this guide. It works fine for installing new and updating existing themes, as well as updating plug-ins. When I attempt to update to the latest (4.3) version of WordPress, or install a new plug-in, the tab I’m using freezes after giving me the loading wheel for a few seconds. The Background Update Tester plug-in gives me the following:

    • PASS: Your WordPress install can communicate with WordPress.org securely.
    • WARNING: A previous automatic background update could not occur. You would have received an email because of this. We’ll try again with the next release. The error code was mkdir_failed_ziparchive.
    • PASS: No version control systems were detected.
    • PASS: Your installation of WordPress doesn’t require FTP credentials to perform updates.

    Also, the following messages are in Apache’s error log:

    [Tue Aug 25 08:22:52.314780 2015] [fastcgi:error] [pid 23286] [client 168.169.225.111:58338] FastCGI: comm with server “/var/www/php5.external” aborted: idle timeout (30 sec), referer: http://domain/wp-admin/update-core.php
    [Tue Aug 25 08:22:52.315275 2015] [core:error] [pid 23286] [client 168.169.225.111:58338] AH00524: Handler for fastcgi-script returned invalid result code 1, referer: http://domain/wp-admin/update-core.php

    Any help would be appreciated. Thanks!

  • The topic ‘Automatic WP Update via SSH not working’ is closed to new replies.