Support » Fixing WordPress » Automatic Upgrade with 2.7.1 — problem

  • I’m having a bit of trouble with this. When I use the “Automatic Upgrade” button, it doesn’t seem to want to go beyond “Unpacking the core update” message. What’s going on?

Viewing 15 replies - 1 through 15 (of 22 total)
  • I had a problem as well with the error message:
    Fatal error: Cannot redeclare pclziputilpathreduction() (previously declared in /home/steve/public_html/wp-content/plugins/wordpress-automatic-upgrade/lib/pclzip.lib.php:5421)

    SD Stern, get rid of that plugin and use the built-in automatic upgrader of WP.

    Phantom, no suggestions. On some installation I had to try twice, but it always worked the second try…

    @phantomobserver

    It’s possible there’s a permission issue with your host, and it’s not allowing the ‘unpacking’ so you may have to follow the Upgrading WordPress instructions to upgrade to 2.7.1

    When trying to upgrade, it also stops at “unpacking the core update” message for me.

    I previously used the plugin auto upgrade (which is deactivated) with no issues.

    Just saw another thread, could the problem be related to the information on this page?

    Alright. I did de-activate the “Automatic Upgrade” plug-in, and the upgrade seems to have worked now.

    My automatic update didn’t work, I’ve lost the error message.

    I’m getting lazy, having only been a user for 2 weeks I’m having to read about updating.

    The backup of the database. Mines at an ISP and so presumably it can’t be backed up. Gotta say I didn’t think of that, so I’m tied to my host now?

    Setting up was easy though and I’m very pleased with it.

    The backup of the database. Mines at an ISP and so presumably it can’t be backed up.

    Of course it can. If they have phpMyAdmin (most hosts do), then it has an Export function which will export the whole database for you to save locally.

    Thanks Otto42. I did a back up. It will be interesting if I have to use it.

    Still not updated though and as I’m so low on the learning curve there is other stuff I’d rather do.

    I had a fatal error when trying to upgrade as well. I followed the suggestion here to deactivate the WP Automatic Upgrade plugin. Now, when I upgrade from the ‘tools’ selection on the dashboard, I get this message:

    Downloading update from http://wordpress.org/wordpress-2.7.1.zip

    Unpacking the core update

    Could not create directory: /home/qselpkpt/public_html/wp-content/upgrade/core

    Installation Failed

    I have no idea what to do now. I always screw something up when I have to do a complete re-install. And I’m going to be very upset if I have to do a complete reinstall every single time there’s an upgrade.

    Does anyone understand the message I posted above? Should I just create that directory myself?

    Thanks so much!

    Having same problem. De-activated the WP Automatic Upgrade plug-in, as suggested above, and upgraded to 2.7.1 flawlessly.
    Thanks.

    I deleted the WPAU plugin altogether, and SP *STILL* won’t upgrade for me. I guess I’m going to have to do like I did every time before 2.7, and just download and completely reinstall the entire thing, and hope I do it right.

    Feh, is the auto upgrade just buggy or something?

    I got the following two errors:

    Fatal error: Call to undefined function wp_user_settings() in /var/www/vhosts/newsbooking.com/httpdocs/wp-admin/admin-header.php on line 14

    Fatal error: Call to undefined method wpdb::has_cap() in /var/www/vhosts/newsbooking.com/httpdocs/wp-admin/includes/schema.php on line 22

    I’d go into my admin, but I can only see my home page! When I click on the admin link (the site is probably cached on my browser…) it comes to one of those warnings.

    Joy. Now what? I’m with DSB, I hate upgrading because it always ends up as a total re-install which is a pain.

    Help anyone? This is really frustrating.

    Thank you!

    whooami

    (@whooami)

    Member

    Joy. Now what? I’m with DSB, I hate upgrading because it always ends up as a total re-install which is a pain.

    Now you manually upload the 2.7.1 files — which, btw, is NOT a total re-install.

    I’m sorry, it’s more of a “total r-install” than the so-called auto. I’m really just frustrated because I got all these “everything was successful! Congratulations, click this button and everything will be fine” sort of message which lead me to the errors I mentioned. If it was successful then why didn’t it work, and now I have to do it manually?

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘Automatic Upgrade with 2.7.1 — problem’ is closed to new replies.