Support » Installing WordPress » Automatic upgrade to 2.8.6 fails

  • Resolved recus


    I press “Upgrade automatically”, it continues to the next page, but the only thing printed is “Downloading update from”. The usual lines of data with info about the upgrade doesn’t show up. When I search for the downloaded file I find it in /wp-content/ but the filesize being 0.

    Tried chmod 777 on wp-content but no luck.
    No files in wp-content/upgrade/.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Backup everything (WordPress Backups.
    Deactivate all plugins.

    Try the upgrade again.

    I had to increase the amount of memory a PHP script may consume. Several ways to do that:

    1. If you have access to your PHP.ini file, change the line in PHP.ini
    If your line shows 32M try 64M:
    memory_limit = 64M ; Maximum amount of memory a script may consume (64MB)

    2. If you don’t have access to PHP.ini try adding this to an .htaccess file:
    php_value memory_limit 64M

    3. Try adding this line to your wp-config.php file:
    define('WP_MEMORY_LIMIT', '64M');

    4. Talk to your host.

    I had this same problem and did the changes and it was a big hassle. alot of memory issues! I logged into my control panel on my host site and they had a screen that popped up that said there was an upgrade. Worked great!

    If you don’t get the upgrade announcement, check your simply script installs page, there might be an auto upgrade there!

    Don’t forget to backup first before you upgrade!

    Disabled all plugins and it worked! Thanks MichaelH!
    Can this be avoided in future releases of WordPress?

    Thanks MichaelH. Your option 2 worked perfectly for me. I’ve been fighting this issue for the last few upgrades. You just simplified my life!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Automatic upgrade to 2.8.6 fails’ is closed to new replies.