WordPress.org

Support

Support » How-To and Troubleshooting » Automatic upgrade to 2.7.1 problem

Automatic upgrade to 2.7.1 problem

  • Hi!

    Auto upgrade from 2.7 to 2.7.1 FAILS with messages:

    Warning: copy(/home/mobi04/public_html/wp-includes/class-smtp.php) [function.copy]: failed to open stream: Permission denied in /home/mobi04/public_html/wp-admin/includes/class-wp-filesystem-direct.php on line 122

    Warning: copy(/home/mobi04/public_html/wp-includes/class-smtp.php) [function.copy]: failed to open stream: Permission denied in /home/mobi04/public_html/wp-admin/includes/class-wp-filesystem-direct.php on line 122

    Can not copy file: /home/mobi04/public_html/wp-includes/class-smtp.php

    What can I do to solve this?

    Tomaz

Viewing 15 replies - 1 through 15 (of 16 total)
  • Same error different file.
    File perms are 0644 on index.php

    Warning: copy(/home/pgphoto/public_html/blog/index.php) [function.copy]: failed to open stream: Permission denied in /home/pgphoto/public_html/blog/wp-admin/includes/class-wp-filesystem-direct.php on line 122

    Warning: copy(/home/pgphoto/public_html/blog/index.php) [function.copy]: failed to open stream: Permission denied in /home/pgphoto/public_html/blog/wp-admin/includes/class-wp-filesystem-direct.php on line 122

    Could not copy file: /home/pgphoto/public_html/blog/index.php

    Installation Failed

    Same here (but different file)

    Warning: copy(/hotel/blog/wp-trackback.php) [function.copy]: failed to open stream: Permission denied in /hotel/blog/wp-admin/includes/class-wp-filesystem-direct.php on line 122

    Warning: copy(/hotel/blog/wp-trackback.php) [function.copy]: failed to open stream: Permission denied in /hotel/blog/wp-admin/includes/class-wp-filesystem-direct.php on line 122

    Could not copy file: /hotel/blog/wp-trackback.php

    Installation Failed

    Same problem here 🙁

    Suggestion to help non-php experts: Shouldn’t it has an optional “Connection Information” panel for that matter –similar to the plug-ins’ one– in order to add the permission credits manually? The plug-in WPAU use to have this option. Probably now the upgrade process is different.

    Question: What is the configuration –exactly– that the server needs to run this upgrade tool? Here http://codex.wordpress.org/Core_Update_Host_Compatibility it doesn’t shows that information, is just a list.

    I changed my file attributes through FTP and that helped. I had to chmod files to 664.

    I am not getting any message after it says unzipping file

    nada.

    Guess I’m the lucky one.

    – I deactivated the automatic update plugin
    – I removed the folder wp-automatic-update (or similar) from my wp-contents/plugins folder on my server
    – in WP admin I clicked on automatic upgrade

    now it says
    Downloading update from http://wordpress.org/wordpress-2.7.1.zip
    Unpacking the core update

    No update is performed.
    Any ideas anybody

    Exactly the same here.

    Folks,

    It may be an owner / group ownership issue. You don’t have access to actually delete the files necessary because the server thinks they don’t belong to you. Not the same as CHMOD. Your server admin may need to fix this.

    I had to chmod all files and directories to 755….is that bad?

    Same problem here.

    I am trying to upgrade to the latest version of WP and am getting the same FAIL message. I have tried to change the permission to class-wp-filesystem-direct.php, but despite this, it reverts to the old permission. I have now spent 40 minutes trying to get this working and trying to find some help on here, but without luck. Help please…

    How long does it take to get a “Success” message, or an error message? I only get to the “Downloading update from http://wordpress.org/wordpress-2.7.1.zip” line and then nothing happens. No progress meters, status updates, nothing. I never used the auto update plugin that was available previously, so that is not my issue.

    Turns out it was a simple matter of switching my server to php5, even though I thought I was already using php5. Oh well, live and learn I suppose. And maybe take a lesson from President Reagan, “trust but verify”.

    I had the same problem and decided to temporarily allow Write permissions to the whole WP root folder and the upgrade went smooth and quick. You can turn the permission back on to Read only after the upgrade is done.

    In both cases make sure you only change permissions in the root folder and not the inherits, as that would affect any special permissions you have given to other folders or files that you don’t want to reset to default.

    It’s funny, I’ve had the same problem – just shows “Downloading update from http://wordpress.org/wordpress-2.8.2.zip” — but nothing happens after that. Permissions are all correct and checked against a second installation on the same server.

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Automatic upgrade to 2.7.1 problem’ is closed to new replies.