Title: Automatic Upgrade snafu
Last modified: August 19, 2016

---

# Automatic Upgrade snafu

 *  Resolved [chalupa](https://wordpress.org/support/users/chalupa/)
 * (@chalupa)
 * [18 years, 5 months ago](https://wordpress.org/support/topic/automatic-upgrade-snafu/)
 * I tried to use the automatic upgrader to go from 2.3.2 to 2.5 and was having 
   a lot of problems with file permissions. I was reading some comments on the creator’s
   site and it said to try a recursive chmod to change permissions on some stuff.
   So I tried that and it was able to get past setting the blog into maintenance
   mode and what not. Well right before I got to the point where it would upgrade
   my database I got several pages of errors all similar to this, for what I’m guessing
   is every file:
 * **Warning: copy(/home/chalupa/public_html/movies/wp-admin/upgrade-functions.php)[
   function.copy]: failed to open stream: Permission denied in /home/chalupa/public_html/
   movies/wp-content/plugins/wordpress-automatic-upgrade/wpau_upgrade.class.php 
   on line 181**
 * So now if I try to go to my blog or my dashboard I get this error:
 * **Fatal error: Call to undefined function require_wp_db() in /home/chalupa/public_html/
   movies/wp-settings.php on line 206**
 * I’m guessing some of the files were upgraded and some were not? I’m also guessing
   my database hasn’t been upgraded yet. I did the auto-backup procedure with the
   plugin and saved those files. I’m not exactly sure what I need to do to replace
   those. Currently my computer won’t let me even see what’s in them because it 
   has deemed them as “unsafe”. Should I just talk to my webhost and have them roll
   back to last week’s backup? I would greatly appreciate any help.

Viewing 2 replies - 1 through 2 (of 2 total)

 *  Thread Starter [chalupa](https://wordpress.org/support/users/chalupa/)
 * (@chalupa)
 * [18 years, 5 months ago](https://wordpress.org/support/topic/automatic-upgrade-snafu/#post-760434)
 * I did some poking around and figured out the plugin changed up a bunch of my 
   file permissions and locked me out of wp-content and wp-includes. I fixed that
   and was able to finish the upgrade.
 * However, now I’m having some database problems. It’s looking like it made a new
   set of tables so it can’t find my username, etc.
 *  Thread Starter [chalupa](https://wordpress.org/support/users/chalupa/)
 * (@chalupa)
 * [18 years, 5 months ago](https://wordpress.org/support/topic/automatic-upgrade-snafu/#post-760451)
 * I had my super-hero college buddy take a look. He fixed some more file permissions,
   and we figured out that a couple files had been truncated. So we re-copied good
   versions of them and now my blog magically works again. Oh yeah, and it’s not
   upgraded. I guess I’ve learned my lesson. Only manual upgrades for me.

Viewing 2 replies - 1 through 2 (of 2 total)

 The topic ‘Automatic Upgrade snafu’ is closed to new replies.

 * 2 replies
 * 1 participant
 * Last reply from: [chalupa](https://wordpress.org/support/users/chalupa/)
 * Last activity: [18 years, 5 months ago](https://wordpress.org/support/topic/automatic-upgrade-snafu/#post-760451)
 * Status: resolved

## Topics

### Topics with no replies

### Non-support topics

### Resolved topics

### Unresolved topics

### All topics
