WordPress.org

Support

Support » Installation » Automatic Upgrade not working

Automatic Upgrade not working

  • bergermark
    Member

    @bergermark

    Hey,

    ever since wp 2.7 I am unsuccessfully trying to use the “automatic upgrade” feature. I start the upgrade and after WP says that it’s downloading the new version, it gets stuck and nothing happens anymore.

    i am using mac os x 10.5.8 and safari 4.0.2.

    Thanks for your help!

    Mark

Viewing 8 replies - 1 through 8 (of 8 total)
  • DigitalAlias
    Member

    @digitalalias

    I’m having the same issue. I’ve had to manually upgrade WordPress each time. I just upgraded and now 2.8.4 is out! I tried the automatic upgrade and it’s stuck doing the same thing –

    Could not copy file: /public_html/wp-content/upgrade/wordpress-2.8.4/wordpress/wp-comments-post.php
    Installation Failed

    I’ve changed the folder permissions to 0777 (/public_html/wp-content/upgrade), but I’m still getting that error. I’m in Windows 3.0.x and Linux 3.5.x.

    flobaby
    Member

    @flobaby

    I just got mine to work after getting the same problem. Not sure which of these two things did it but I changed my permissions on that file to 777 and also deleted the previous upgrade folder (because I noticed it still said 2.8.3).

    bergermark
    Member

    @bergermark

    What means changing the folders permission to 0777?

    i deleted the previous upgrade folders, but that didnt help.

    Hi!

    I read all the posts and tried every suggested hint. Nothing worked. Then I just backuped the whole WordPress installation to a local drive, deleted WordPress installation on server and copied backup back to server. Automatic upgrade then worked like a charm on first try :). Take care about any directories/files that may need special rights re-established.

    I hope I will not have similar upgrade problems later on when new upgrade becomes available. I know this is not a real solution, more like time saver workaround.

    My upgrades have not been working either. I have at least 5 wordpress sites.

    They haven’t been working for at least the last 3 versions. Is there anyone working on a fix?

    I also think the whole idea of having to use a user name and password to do the upgrades bites. It was so much better the old way.

    add the following line to the .htaccess file (the top of the file)

    AddType x-mapp-php5 .php

    That should do it!

    Thanks gjperera! I had been having no luck with automatic upgrade (suddenly – it always used to work). Your tip made it work again – brilliant!

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Automatic Upgrade not working’ is closed to new replies.