Support » Fixing WordPress » Automatic Upgrade Not working

  • Ok, so I have not been able to use the automatic upgrade since it was released on one of my wordpress websites. It has killed me everytime they come out with a new update. This also included not being able to update plugins automatically or take advantage of the sweet install feature straight from the backend. Here is the weird thing, I have test wordpress sites for development set up on the same server and some of them can do the automatic, some can’t. I’ve tried wiping out wordpress and reinstalling on my main site (which is where I am having the problems) with no luck. I have read a thousand forums and can’t find anything that helps. I’m wondering if there is anyone who can give me some insight! PLEASE HELP!

    My site is epic4life.com. Thanks in advance!

Viewing 15 replies - 16 through 30 (of 30 total)
  • Upgrade is there, have done all three of those suggestions and got nothing. I finally just manually upgraded once more… I did go into my phpmyadmin in cpanel for an unrelated issue, and while in there noticed that there was no data in the upgrade log for the wordpress installs I’ve been having issues with but that the ones that have been upgrading have logs… I wonder if there is a problem with the database or the user of the database or something…

    Hi,
    I have a similar upgrade issue, however the upgrade only gets to the step of unzipping the files and no further.

    I am using the automatic upgrade which has worked fine for me up till now. Has anyone else had this problem and discovered a solution?

    Output:

    Downloading update from http://wordpress.org/wordpress-2.9.2.zip.

    Unpacking the update.

    Moderator James Huff

    (@macmanx)

    Halfelf Minion 🚀

    Make sure that you have enough space left for the update package to be fully decompressed.

    Checked disk space and I have 300Mb free. I hope that is sufficient space.

    Moderator James Huff

    (@macmanx)

    Halfelf Minion 🚀

    That should be enough. My next guess would be that your server doesn’t have whatever is needed to unpack the update. Can you do a manual upgrade?

    Thanks macmanx I will have to go the manual upgrade route I guess.

    Previous automatic upgrades have worked fine. They were very quick and easy hence I wanted to keep on using this upgrade approach.

    Thanks for the advice.

    Moderator James Huff

    (@macmanx)

    Halfelf Minion 🚀

    You’re welcome! If you wanted to, you could ask your hosting provider if anything has changed recently on the server side to prevent the automatic upgrade.

    There is one last thing to check when all else fails. Depending on the default memory limit for your PHP installation you may be constrained by a low default. For me the telltale sign was that the zip file would download fine, hence it wasn’t a permissioning issue.

    You can increase the memory limit by adding the following to your .htaccess file (assuming you have access to this file)

    AddType x-mapp-php5 .php
    php_value memory_limit 64M

    The first line tells apache to process .php files with the php5 module. The second increases the memory. (check with webhost to make sure this is supported)

    Alternately you can add the following to your wp-config file:
    define(‘WP_MEMORY_LIMIT’, ’64M’);

    Again, this requires that your host allow you to increase the php memory.

    – Trip

    Well, it’s that time again, WordPress updates and I’m left with only a manual install: SoundTrip, I tried your idea – need to double check with my host and just make sure that I am allowed to do it, but it did not work – is there a way to check and see if the memory was increased?

    Here is the new failure report I am getting from WordPress:

    Downloading update from http://wordpress.org/wordpress-3.0.1.zip…

    Unpacking the update…

    Could not create directory.: /public_html

    Installation Failed

    In my PHP Configuration file it says:

    Resource Limits memory_limit Maximum amount of memory a script may consume (32MB) 32M

    Is there any way to change this from within cPanel?

    Sorry to keep posting, but I got this from my server peeps:

    We do not have fix but it happen if database repair without lock tables or
    if search query run by many user at 1 time

    or mysql restart frequently.

    I’m not even sure what that means – can anyone explain or help? I am still having the issue that started this whole thread…

    Memory has been upgraded to 64M still no luck. Suppose I will upgrade manually…

    I am having this exact same problem on only one of my sites (which are all hosted the same place and haven’t done anything different to any of them). Would love to know a solution if anyone has one!

    The best solution I have found to automatic update issues like this is fixing the ownership/permissions on the upgrade folder.

    To do: delete the upgrade folder in wp-content.

    Recreate the folder and reset permissions to 777

    Thanks seriocomic! After dealing with this problem for some time, and having to perform manual installs, I found this thread, changed the permissions on my upgrade folder from 755 to 777 and now my auto-upgrade on plugins and site worked without any glitches. 🙂

Viewing 15 replies - 16 through 30 (of 30 total)
  • The topic ‘Automatic Upgrade Not working’ is closed to new replies.