WordPress.org

Support

Support » How-To and Troubleshooting » Automatic Upgrade Not working

Automatic Upgrade Not working

  • kentopolis

    @kentopolis

    Ok, so I have not been able to use the automatic upgrade since it was released on one of my wordpress websites. It has killed me everytime they come out with a new update. This also included not being able to update plugins automatically or take advantage of the sweet install feature straight from the backend. Here is the weird thing, I have test wordpress sites for development set up on the same server and some of them can do the automatic, some can’t. I’ve tried wiping out wordpress and reinstalling on my main site (which is where I am having the problems) with no luck. I have read a thousand forums and can’t find anything that helps. I’m wondering if there is anyone who can give me some insight! PLEASE HELP!

    My site is epic4life.com. Thanks in advance!

Viewing 15 replies - 1 through 15 (of 30 total)
  • Perhaps you have 1 or more problematic plugins? Or a bad theme that is affecting the auto installs & upgrades? Try deactivating all plugins and/or switching to the default theme.

    equalmark

    @equalmark

    We have just had this problem with one of our sites and the reason was because the files of the server (WordPress files) were not owned by the Apache web server user. Once this was fixed the auto update was able to work again.

    kentopolis

    @kentopolis

    how did you make the files “owned” by the the Apache web server user?

    equalmark

    @equalmark

    I didn’t!! I asked my web host and they sorted it for me. Perhaps you could do the same?

    kentopolis

    @kentopolis

    How did you figure out which files to have them change?

    kentopolis

    @kentopolis

    equalmark: Oh, you’re talking about permissions, I have changed all my permissions and tried all the tricks with that and can’t get it.

    esmi:
    I have also tried uninstalling all my pluggins and various themes – nothing helped.

    kentopolis

    @kentopolis

    The other weird thing, only one or two of the test sites automatic upgrades, but others won’t do the automatic upgrade at all – they act like the main site…

    This is what I get when it fails upgrading wordpress:

    Downloading update from http://wordpress.org/wordpress-2.8.6.zip.

    Unpacking the update.

    Could not copy file: /public_html/kent/wp-content/upgrade/wordpress-2.8.61/wordpress/wp-comments-post.php

    Installation Failed

    atanone

    @atanone

    What is the version of php being used there? I had trouble in one of my site until I found out that I hadn’t updated the php in the site from php4 to php5. Once I made the switch, the automatic update worked right away.

    kentopolis

    @kentopolis

    What is the version of php being used there?

    PHP 5.2.5 in the c-panel – is it possible for the site to still be using an older version?

    Also, the test sites (all of them both the ones that work and don’t work) are all on under the same domain, just different folders, ie. epic4life.com/wp (upgrade works) & epic4life.com/kent (doesn’t work)

    kentopolis

    @kentopolis

    Ok, I went file by file and changed every permission in my install that doesn’t work to match that of my install that does work. I still get this message though:

    Downloading update from http://wordpress.org/wordpress-2.8.6.zip.

    Unpacking the update.

    Could not copy files.

    Installation Failed

    Any ideas?

    equalmark

    @equalmark

    Could not copy files says to me a permissions problem – perhaps on the wp-content folder.

    kentopolis

    @kentopolis

    content permissions are set to the same as the install that is working on the same server

    So, it is happening again to me… I am trying to upgrade my root install to 9.2 and all I get is problems. It is such a pain to upgrade manually when you know this should be working…

    Here is the error I got again:

    Upgrade WordPress

    Downloading update from http://wordpress.org/wordpress-2.9.2.zip.

    Unpacking the update.

    Could not copy file: /public_html/wp-content/upgrade/wordpress-2.9.2/wordpress/wp-comments-post.php

    Installation Failed

    PLEASE HELP!
    I can’t upgrade pluggins either…

    Check if there is a directory named “upgrade” in wp-content?

    During the process WordPress needs this one for temporarily writing some files.

    I occasionally get the same problem. Here’s three options I’ve used to solve it:
    1) keep trying the automatic upgrade
    2) do a manual upgrade
    3) ftp to public_html/wp-content/upgrade/ and delete the folder with a .tmp extension. Then try auto upgrade again. If you go into that folder before you delete it, you’ll probably see only a few wordpress files. This means files were being transferred, but something cut them off.

Viewing 15 replies - 1 through 15 (of 30 total)
  • The topic ‘Automatic Upgrade Not working’ is closed to new replies.
Skip to toolbar