[resolved] Automatic Upgrade WP 3.0 Not Working (21 posts)

  1. dominick41
    Posted 5 years ago #

    We have tried all day to upgrade to 3.0
    here it shows in the tools page

    Upgrade WordPress

    Downloading update from http://wordpress.org/wordpress-3.0.zip.

    that is it. Nothing happens, all plugins have been updated........

    our host AT&T is still only supporting 2.83, they are on the ball..so they won't help at all, so we are not in a hurry to do it manually.......
    Any Suggestions?

    Dominick from WSOPNE.org

  2. I think you'll have to do a manual upgrade in this case.

  3. dominick41
    Posted 5 years ago #

    But what would cause the auto update not to work?
    does anyone know, is it a plugin..ect/?

  4. Safirul Alredha
    Posted 5 years ago #

    Even it's not cause by plugin, before upgrading it is wise to deactivate all your plugins first.

    btw, how long did u wait? 5 minutes?

  5. dominick41
    Posted 5 years ago #

    well, I did not wait a long time, they have always been fairly fast in the past.........does it take a while?

  6. No, it really should have happened in about a minute. You could try doing it again with your plugins disabled.

  7. cruth
    Posted 5 years ago #


    Another suggestion Just wanted to throw this idea out there.

    I have started upgrading various installations to 3.0, failing often.

    One of the tricks I just tried (again) was to JUST DELETE some of the plugins I really don't need. and, I did this inside of wordpress (as opposed to thru CPanel or FTP).

    I then tried the automatic upgrade again, and it worked.

    Sometimes this works; sometimes not.

  8. Momekh
    Posted 5 years ago #

    I tried Cruth's advice, as plugins usually are the culprits in these cases (which is understandable of course).

    but if it is any help, I had the wp-spamfree plugin that was causing the trouble. I also run a few blogs and many of them were not upgrading automatically.

    Wp-spamfree is a super plugin, I think, as it makes spam fighting very easy. But they have not upgraded their plugin to work with wp 3.0. which is bad. :/

    anyways, hope this has helped.

  9. xuefang
    Posted 5 years ago #

    My WordPress version is 2.7, so I used the automatic upgrade from my dashboard. I deactivated all my plugins before doing the automatic upgrade login as admin and using my username to do the automatic upgrade.
    I have the following error:
    Could not copy file: /public_html/wp-content/upgrade/core/wordpress/wp-activate.php

    It's my first upgrade and am not too sure whether I should aim for manual
    Any pointers?


  10. webduck
    Posted 5 years ago #

    I deactivated the spam free plugin and got this error message I had never gotten before:

    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 2965231 bytes) in /home/ipenwil9/public_html/wp-includes/http.php on line 1358

  11. First, try installing the Memory Bump plugin.

    If that doesn't work, here are four more ways to increase PHP's memory allocation:

    1. If you have access to your PHP.ini file, change the line in PHP.ini
    If your line shows 32M try 64M:
    memory_limit = 64M ; Maximum amount of memory a script may consume (64MB)
    2. If you don't have access to PHP.ini try adding this to an .htaccess file:
    php_value memory_limit 64M
    3. Try adding this line to your wp-config.php file:
    Increasing memory allocated to PHP
    define('WP_MEMORY_LIMIT', '64M');
    4. Talk to your host.
  12. dominick41
    Posted 4 years ago #

    I had deactivate and delete a plug in
    finally a plug in called super slider was the problem!

    automatic update worked instantly!!!!!!!!!!!!!!
    Thanks everyone
    That almost drove me nuts...come visit us folks wsopne.org

    God bless you all.......

  13. You're welcome!

  14. websuccessteam
    Posted 4 years ago #

    Hi, I deleted all my plugins. Still no luck automatically upgrading to 3.0. I get this message "Unpacking the update." and then nothing happens. I don't really want to re-install everything. Any suggestions?


  15. websuccessteam, your server is missing the necessary software to unpack the archive. You'll have to upgrade manually:


  16. websuccessteam
    Posted 4 years ago #

    THX MacManX. Can't seem to find the .htaccess file could that be the reason I can't upgrade?

  17. Rev. Voodoo
    Volunteer Moderator
    Posted 4 years ago #

    2 possibilities:

    If you never set up pretty permalinks, you may not have a .htaccess

    You may need to unhide hidden files

  18. Vidhu
    Posted 4 years ago #

    Hi all...
    I tried to upgrade wp 3.0.1 for last 4 hrs. Its showing
    "Upgrade WordPress
    Downloading update from http://wordpress.org/wordpress-3.0.zip."
    That's it but no change. I too tried by wordpress-automatic-upgrade plugin. That too gives me same result. But both automatic upgrade and plugin are working in my local host but not in my live server :( Pls help me in this...

  19. vidhu, your server is missing the necessary software to unpack the archive. You'll have to upgrade manually:


  20. Vidhu
    Posted 4 years ago #

    Hi James.,
    Yes i followed the link given by you and i have upgraded successfully..
    Thank you very much:-)

  21. You're welcome!

Topic Closed

This topic has been closed to new replies.

About this Topic