Automatic Upgrade Failure (1&1 fix didn't work) (8 posts)

  1. steve.h
    Posted 6 years ago #

    I've attempted to upgrade two different wordpress installs on my server (one at the root - stevehenningsgard.com, and one in a different folder acting as a root directory for a different domain - ironthrones.com), and neither has worked automatically. They both fail at the same spot:


    Downloading update from http://wordpress.org/wordpress-2.8.4.zip.


    It will create a file in the wp-content folder "wordpress-2.8.4.zip", but it will have a zero-byte size, and will never get any further.

    I tried to manually upgrade ironthrones.com, and now I can't approve comments, or upgrade or enable some plugins.

    After reading several suggestions relating to the .htaccess file and 1&1 web hosting, I created an .htaccess file with the following code:


    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule ./index .php [L]

    AddType x-mapp-php5 .php

    # END WordPress


    ...which had no perceived effect. Please help!

  2. Try

    AddHandler x-mapp-php5 .php

    in htaccess, too.

    And then do a manual reupgrade as possibly some of your files got damaged on upload.

    Keep in mind that 1&1 might have some PHP security restrictions that break some plugins; Google the name of the plugin and 1&1 and see what you come up with.

  3. steve.h
    Posted 6 years ago #

    Thanks for the help/reply, songdogtech!

    I'll add that and see what happens.

    Could you define a manual re-upgrade? As the automatic upgrade process never got past trying to download the zip file, I wouldn't imagine it would've goofed up any other files, but I could of course be wrong!


  4. Hope some of this works. It's two different upgrades:

    for ironthornes, do the upgrade over again; some files might have been inadvertently damaged or didn't complete on upload. The only plugin that is loading is antispam, so I don't know what other plugins you have that aren't working.

    Try a manual upgrade for stevehenningsgard; sometimes the autoupgrade has problems with directory permissions, i.e. creating directories and subdirectories on a host.

  5. etow
    Posted 5 years ago #

    Thanks songdogtech. Adding "AddHandler x-mapp-php5 .php" in addition to "AddType x-mapp-php5 .php" to my .hattaccess file on 1&1 allowed automatic updates to work. I don't know if "AddType x-mapp-php5 .php" was necessary because I did not try it with just "AddHandler x-mapp-php5 .php".

  6. ccagle8
    Posted 5 years ago #

    I had the same problem with 1&1, and doing what etow suggested did work.

    AddHandler x-mapp-php5 .php
    AddType x-mapp-php5 .php

    was added to the top of my .htaccess file - perfect downloads now. Thanks!

  7. J-Reese
    Posted 5 years ago #

    Very interesting. I have been using WordPress since version 2.5 and since the "Automatic Upgrade" feature was introduced I have not had luck with it working and it would just sit at the first step forever. Tonight I finally came looking for answers because it bothered me enough and this was just the information I needed for my 1&1 hosting. Thanks!

    Question though - would anyone care to explain what these two lines instructions are actually doing? I am glad it is finally working after all this time but I would kind of like to know what I am putting in there.

  8. James Huff
    Volunteer Moderator
    Posted 5 years ago #

    would anyone care to explain what these two lines instructions are actually doing?

    The two lines enable PHP 5 on your account. Personally, I find it odd that 1&1 insists on leaving PHP 4 (a branch that was discontinued over two years ago) as the default on their customer's accounts and still offer no simple way to enable PHP 5.

Topic Closed

This topic has been closed to new replies.

About this Topic