Support » Plugins and Hacks » Automatic Upgrade Broke

Automatic Upgrade Broke

  • I just tried upgrading to 2.6 with WordPress Automatic Upgrade. I had given the FTP details to upgrade and now I cannot access anything under my wordpress directory.

Viewing 15 replies - 1 through 15 (of 17 total)
  • I’m having the same problem, basically. I can’t login to the dashboard. I have the correct user name and password, but it says “Login again.” I tried changing my password and that doesn’t work either.

    Oh, and I used Automatic Upgrade…I saw that mentioned in another post.

    Is there a way to undo the upgrade?

    I’m not sure what the update did. I hit “Begin Update” and then there was a ‘Continue’ link that I clicked. Then I noticed that everything under my wordpress directory didn’t work anymore.

    Hmm…I just upgraded from 2.5.1 to 2.6, but did NOT use the automatic upgrade, and now I cannot login IF I use Firefox (v3.0). I try and then it takes a minute and says “Please login again.” I am able to login using Internet Explorer 7, though.
    That also seems to be my only issue. Have the other posters to this topic only tried to login post-upgrade using FireFox?

    So I should’ve tried this before I posted, but I had to actually delete my cookies and then I was able to login. Kinda weird; should’ve thought of that immediately; regardless, it worked.

    I can’t access anything in my wordpress directory, still. I can access the index file, which isn’t part of this directory. I have no clue how this happened, other than WPAU has somehow changed something somewhere I can’t find it. I’ve uploaded all of the WP 2.6 files, and the same is happening. I don’t know how to disable the WPAU plugin without the admin interface…

    Anybody have ANY ideas? I’m on my last rope here…

    Moderator Samuel Wood (Otto)


    WordPress.org Tech Dude

    Upgrade manually. Automatic Upgrade does not work.

    Just upload the WordPress 2.6 files to your site.

    I did, and I still can’t access anything. I deleted my previous wordpress files, and did a clean install. With/without plugins. I have no idea where the site is all of a sudden giving me 404s. The files ARE there. In my error log I am getting a lot of this:

    [16-Jul-2008 00:08:51] PHP Fatal error:  require() [<a href='function.require'>function.require</a>]: Failed opening required './press/wp-blog-header.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/getxagn1/public_html/whatsleet/index.php on line 4
    [16-Jul-2008 00:08:52] PHP Warning:  require(./press/wp-blog-header.php) [<a href='function.require'>function.require</a>]: failed to open stream: No such file or directory in /home/getxagn1/public_html/whatsleet/index.php on line 4
    [16-Jul-2008 00:08:52] PHP Warning:  require(./press/wp-blog-header.php) [<a href='function.require'>function.require</a>]: failed to open stream: No such file or directory in /home/getxagn1/public_html/whatsleet/index.php on line 4

    Everything else works, until it needs an actual file it seems. Look: http://www.whatsleet.com I can’t do press/wp-admin/upgrade.php. I can’t do press/wp-login.php or anything of this sort. I think something messed up in the .htaccess file? I have no idea…

    Moderator Samuel Wood (Otto)


    WordPress.org Tech Dude

    [16-Jul-2008 00:08:52] PHP Warning: require(./press/wp-blog-header.php)… No such file or directory

    Are you sure that the files are all there? If it can’t open it and it’s not there, then that’s probably bad.

    On the other hand, if the file *is* there, then it’s probably some kind of permissions issue. Make sure the file is readable and such.

    It is definitely there. Is that file even called from accessing wp-admin, though?

    I am also seeing this:

    [16-Jul-2008 12:19:57] PHP Warning:  require_once(/home/getxagn1/public_html/whatsleet/press/press/wp-load.php) [<a href='function.require-once'>function.require-once</a>]: failed to open stream: No such file or directory in /home/getxagn1/public_html/whatsleet/press/wp-blog-header.php on line 12
    [16-Jul-2008 12:19:57] PHP Fatal error:  require_once() [<a href='function.require'>function.require</a>]: Failed opening required '/home/getxagn1/public_html/whatsleet/press/press/wp-load.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/getxagn1/public_html/whatsleet/press/wp-blog-header.php on line 12

    Where it is repeating the /press directory. I think I may have fixed this, however, I am not seeing any of these errors anymore. But, my wp-admin problem still exists, just as other files being executed. What should these files permissions be?

    I tried using this plugin and now my site not only has NOT been upgraded, but it is now stuck in maintenance mode. I deactivated the plugin but the maintenance mode still will not go away. I can log into the admin area but that’s about it.

    BTW, I did the “fix” on the FAQ page to get it out of maintenance mode, but that did not work. I guess the only real fix will be to manually upgrade instead of trying to figure out the mess that this terrible plugin has made.

    suppose i should have made a forum check first, but yea, since i saw this brilliant plugin in my dashboard i decided to just make a back up and give it a try.

    what a waste of time, the plugin took me through the countless “pseudo-automatic-steps” and now i’m also stuck in “maintenance mode”.

    I’m not sure about maintenance mode, but I checked my permissions, and apparently I was also having connection problems at the time so some of my files were not successfully CHMOD-ed back to their original permission.

    Thanks, for your help, Otto.

    I wish I never upgraded – there are more problems in this release than I can count and i have yet to find a single improvement. I’ve no idea how this can be called a stable release.

    Image placement – did your beta testers not try aligning an image?

    When editing – won’t allow the clicking before the first character

    When editing and dragging to pick up a sentence it STILL picks up half of the previous code.

    Line breaks are a wild and crazy thing – you never know whether they were input or not. The HTML view gives you a kind of idea, but the WYSIWIG isn’t even close.

    What’s the image box that gets in the way now? How does that help other than getting in the way?

    Back to image align – I have to manually change the code every time because there’s a ” missing.

    When selecting a graphic and inputting you select which alignment and guess what – makes no difference.

    I could sit here all day – I thought that what Beta testers were for? I can’t believe anybody created even oine post without seeing all of these issues.

    I sound frustrated only because I was suckered into upgrading – when the answer of course is if it aint broke don’t fix it. While 2.5.1 has a hundred issues at least I what they are. Downgrading to 2.6 makes as much sense as feeding fine chocolate to kittens.

    I used WordPress Automatic Upgrade Plugin by Keith Dsouza, followed the back up prompts and all when smooth. All the files and data were backed up to my HD, however I did not have to use them. Then all files were updated automatically. No password input or anything else.

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘Automatic Upgrade Broke’ is closed to new replies.