Support » Fixing WordPress » Automatic updates failed

  • I have 2 sites running 3.4.2. Trying to upgrade themes or plugins, the update runs and says it is successful, but no update is to be found. Same thing happens when trying to add a new plugin through the automatic upload. I finally figured out that a second folder has been created, i.e.:
    /home/user/home/user/public_html/wp_content/plugins/ and the files have been uploaded there instead of to:

    Any idea why this is happening and how to fix it?

    I have other sites on the same server that I have not updated to 3.4.2 yet, they are still on 3.4.1 and they are not experiencing the same issue.

Viewing 4 replies - 1 through 4 (of 4 total)
  • you can contact your hosting provider he can help you it might be related to permission settings of your files and folders

    Actually, my hosting provider is at a loss also. How would it be related to permission settings? If it is unable to write to the plugins directory it would go ahead and create a new home and username directory under the site root that it could write to? Can you point me to the file containing the function for this so I can have a look at it to see what it is doing?

    I also faced similar problem than i login to my File manager for updating files but it gives me error. I was using windows server.
    After some time moved to Linux server.
    it will not create new directory with same name.
    can describe the error you are getting at time of update.

    I have found out that the problem was caused by WooDojo plugin – I did a new install, and everything worked properly until I installed that plugin and tried to activate one of the components within it. Now that site is broken just like the other ones. I still don’t know how to fix it, but at least I know what caused it.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Automatic updates failed’ is closed to new replies.