Support » Installation » [Resolved] Automatic update to 3.5 failed

[Resolved] Automatic update to 3.5 failed

  • I tried to automatically update to 3.5 and it failed.

    By deleting the .maintenance file and the upgrade folder I was able to restore my site.

    However I can’t seem to access the admin section and I’m seeing the following error…

    Fatal error: Call to undefined function get_taxonomies_for_attachments() in /home/content/34/7971934/html/main/wp-admin/menu.php on line 67

    Does anyone know what to do to fix this problem? Any help would be greatly appreciated!

Viewing 15 replies - 1 through 15 (of 21 total)
  • same here, we shouldn’t update wordpress so early… It’s seems to beta version still

    I only did it because it told me too. I don’t think they would push a beta like that would they?

    Very frustrating.

    Same here. Updated 2 sites just fine, third one doesn’t want to at all, always giving me the same error.

    Found it ! click

    The doesn’t link to anything?

    I am having the same problem on one of the websites I run (after update to 3.5), any help getting pointed in the right direction would be much appreciated. Thanks



    Can someone please tell me how to embed video with 3.5 please my jw player wont work

    Hey guys having the same problem since updating to the new 3.5 version…
    Fatal error: Call to undefined function get_taxonomies_for_attachments() in /home/public_html/wp-admin/menu.php on line 67

    Please help anyone! I’ve tried renaming the plugins folder but that doesn’t work.

    Fatal error: Call to undefined function get_taxonomies_for_attachments() in /home/public_html/wp-admin/menu.php on line 67

    This error unfortunately means your upgrade didn’t complete successfully, there’s no easy way around this – you’ll need to re-upload your WordPress files.

    In order to do this, you’ll need to download the WordPress .zip file, and FTP all the files from the zip (other than wp-content) to your host, using the instructions here:

    In the steps it says to do the wp-content…should this just be skipped? Also when deactivating the plugins manually does this mean they’re deleted? Or just temporarily unusable? One of the plugins I use is for a forum and can not afford to lose it…

    Thanks again for the help!

    Just hopping in halfway the discussion, but if you have problems with a running website, you can deactivate all plugins by renaming the /wp-content/plugins folder (just rename, do not delete).
    You probably don’t have to edit wp-config.php, but don’t overwrite it. On the other hand, making a new one never hurts, since even wp-config.php has been changed over the years.
    If all fails, just remove all wp files except wp-config.php (but note my earlier remark) and wp-content/themes and upload the files using FTP and using an unzipped file from the download link on top of this page.

    Ok just finished my manual install and everything is back to normal!

    I managed to access the dashboard by replacing the menu.php file from the 3.5 update with the 3.4 menu.php.

    And now I’m trying the 3.5 update again, fingers crossed.



    Forum Moderator

    No! You cannot mix files like that! Try re-uploading all files & folders – except the wp-content folder – from a fresh download of WordPress. Make sure that you delete the old copies of files & folder before uploading the new ones.

    If you continue to have problems, please post your own topic.

    The update does take a while, I think the first time I tried to press the update button twice, maybe that’s what caused the problem?

    Still updating…

Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘[Resolved] Automatic update to 3.5 failed’ is closed to new replies.