Support » Plugins » Automatic update of plugins fails

  • Hello,

    all day I tried to update several plugins using the automatic update function. I appears that wordpress has the problem every time that it cannot write the new plugin file to the folder “/wp-content/upgrade/”. So this error occurs every time:

    Warning: unlink(/wp-content/upgrade/ [function.unlink]: No such file or directory in /wp-admin/includes/class-wp-upgrader.php on line 146

    Archive is not compatible PCLZIP_ERR_MISSING_FILE (-4) : Missing archive file ‘/wp-content/upgrade/’

    Permissions of /wp-content/upgrade/ are set to 777.

    When I manually upload the file “” to /wp-content/upgrade/ WordPress deletes the file and the same error occurs.

    Would be nice if you could help me because I need to update the plugins for security reasons.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Hello,

    Not sure if this is the same as your problem but when my wp
    automatic update plugins failed, I was able to just delete the
    previous version and it’s folder at my ftp. It was in the “plugins folder” I copied it first to my hard drive in case. Then after clicking “plugins, add new,”
    I was able to get the file uploaded from my downloaded location
    (this case desktop) by clicking the browse button and grabbing it.
    At that point the ugrade function asked for the password to the ftp
    and did it’s thing and it installed.

    If that way still wont work you can try sending the plugin folder
    after you unzip it, to the directory /wp_content/plugins not /upgrade
    log out restart your browser, log back in and look for the plugins to be activated and there is a good chance it will be there then click activate.

    I didn’t have to do it that way but it still could work as long as the server will read the script and what is there.

    Hope it helps



    In my case I tried it a number of times and the system just hung up leaving my blog in “Maintenance Mode” so that it’s stuck. I end up having to shut down the browser and wait a few minutes to get back in.

    So far, I’ve not been able to upgrade any of the plugins.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Automatic update of plugins fails’ is closed to new replies.