Automatic Update never has worked (5 posts)

  1. heiseheise
    Posted 6 years ago #

    I'd like to try to use the Automatic Update feature introduced with 2.7, but it has never worked. It has always just sat at

    Downloading update from http://wordpress.org/wordpress-x.x.x.zip

    and has never gone any farther. It's not frozen; I can leave the page normally and everything runs at normal speed, but it just never gives me any other text beyond that line.

    I am using 1and1.com basic hosting plan, and MySQL 4, and PHP4 too I believe. Could that be causing this issue?

  2. heiseheise
    Posted 6 years ago #

    Oh yes, and I know that wordpress will fail (with error code) if PHP4 has not been fooled with the xmapp code in the .htaccess file. Already did that. And it's a different issue; in my case it doesn't even get to an error code! - although I wish it would; it would give me something else to go on.

  3. AnubisibunA
    Posted 6 years ago #

    in 1and1's FAQ's... there something about making your server space use the .php5 extension [ which is what your problem is ].

    I had the same thing with 2.7 because the auto-updates require php5 and 1and1 won't work w/o editing the server php variables or whatever it is.

    Create a .htaccess file and place the following line AddType x-mapp-php5 .php in it.
    This will tell Apache to use PHP 5 instead of PHP 4 for the extension .php in the
    directory the .htaccess is placed and all sub-directories under it.
    You can use AddHandler x-mapp-php5 .php as an alternative for or instead of
    AddType x-mapp-php5 .php

    This one might help [ http://faq.1and1.com/scripting_languages_supported/php/9.html ]

  4. heiseheise
    Posted 6 years ago #

    okay, well I had already tried that with my main .htaccess file in the root of my storage space, but do I need to remake a new .htaccess file say, in the /admin/ folder as well with the same instructions? I'm missing some step here.

    But I was under the assumption that it would fail with an error code, not just hang - did you get an error code when you were having this issue, Anubis?

  5. perrij3
    Posted 6 years ago #

    You have to edit the .htaccess in the main root director. Add the following code on the line after #End WordPress

    AddType x-mapp-php5 .php
    AddHandler x-mapp-php5 .php

    If you attempted to upgrade wordpress and it did not work and you are missing 1/2 your dashboard, this will also fix that.

Topic Closed

This topic has been closed to new replies.

About this Topic