Support » Installing WordPress » Automatic Update Failure

  • It has worked before, but now it simply wont work.

    Download updates from http://sv.wordpress.org/wordpress-2.9.1-sv_SE.zip.
    
    Unpacking the update.
    
    Could not copy files.
    
    Installation failed

    If I knew which directory it can’t copy files to I could easily fix it by changing permissions. But the error report makes me kind of stranded.

Viewing 10 replies - 1 through 10 (of 10 total)
  • To the directory you specified in your Dasboard/Settings ususally wp-content/uploads

    What makes you think that this is a permissions issue? Did you see an error about permissions. If you have a look in your access/error logs you might find more information. Have you tried to do a manual update and see if that works?

    @ henkholland:
    That directory is set to 777.

    @ rakxzo:
    Since it says “Could not copy”. It gets downloaded, it gets unpacked, and then it crashes.

    Where do I find those logs?

    Ok, why bother? Get FTP and unzip locally and upload over FTP.

    @ henkholland:
    This issue is not about uploading via FTP. It’s about getting the Automatic Updater to work and try to hunt down any possible bug or config/permission-issue.

    Yeah, I understand Deathgasm by when there is a standard second option (ftp) , why waste time?
    For my part, they could take out the automatic upgrade button so that only people upgrade when they have some knowledge and they create less problems for themselves. Sorry, OT.

    @ henkholland:
    If you had a product and a feature was broken, would you skip it and tell the people that used it to do it some other way? Didn’t think so.

    What do you mean with this:

    For my part, they could take out the automatic upgrade button so that only people upgrade when they have some knowledge and they create less problems for themselves. Sorry, OT.

    Are you trying to look down on my knowledge because the feature does not work as intended?

    All posturing aside…

    Is your host running PHP4 or PHP5? With some hosts I’ve had to add this to the .htaccess file to get auto updates to work:

    AddType x-mapp-php5 .php

    @ Cris_K:
    It’s running PHP5, Apache, Ubuntu Linux and MySQL5.

    Would be neat if it created some kind of error log to tell WHY the files could not be copied.

    @deathgasm:

    Are you trying to look down on my knowledge because the feature does not work as intended?

    Absolutely not!!
    When I wrote that I just answered on three other posts that went like this: “I hit the automatic upgrade button and now I am getting a blank page etc etc”. And then ususally they do not haven backups, did not deactivate their plugins etc etc because they were not forced to read some instructions before hitting the button that shows up upon every login.

    Back on topic. Sorry, I am only familiar with a simple workaround (ftp) since automatic never worked for my setup (three sites).

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Automatic Update Failure’ is closed to new replies.