Support » Plugin: Disqus Comment System » Automatic Syncing no longer available

Viewing 8 replies - 16 through 23 (of 23 total)
  • Plugin Author brevityness

    (@brevityness)

    I have just deleted Disqus plugin, reinstalled/activated it, gone to the wordpress installation page on Disqus, pasted the sync token, clicked “install” and got the following message:

    What’s the link of the page where you clicked the “Install [sitename] on your site”. It should be https://[shortname].disqus.com/admin/install/platforms/wordpress/

    What’s the link of the page where you clicked the “Install [sitename] on your site”.

    That is correct. I just tried reinstalling again to doublecheck. It goes to the following link:
    https://[myshortname].disqus.com/admin/install/platforms/wordpress/

    The message is the same: “An error occurred trying to configure your site. Make sure the Disqus plugin is installed and activated, and that your site is publicly accessible.”

    The plugin is installed and activated; my site is publicly accessible; Disqus commenting system appears to be working on the site. However, in the wp-admin area for a post that has comments, it says “no comments yet”. Because automatic sync’ing has not been set up.

    It’s a vicious circle.

    Is it because I have not yet updated to the very latest version of WP? (I have not had time to do the backups necessary before updating. I was under the impression that this latest WP update was NOT a security update.)

    So. I jumped to configuration in the Disqus admin area and got the message:

    Setup Complete!

    Congratulations, you finished installing Disqus! Here are a few pages to help you get started using Disqus.

    But. Sync’ing is still not completed.

    Please advise.

    Plugin Author brevityness

    (@brevityness)

    Hmmm it’s possible that another plugin is interfering with the set up process. You could try disabling other plugins and attempting to re-install again to see if that works.

    Otherwise, I’d recommend checking out our instructions for manually setting up comment syncing here: https://help.disqus.com/import-export-and-syncing/syncing-with-wordpress

    Hmmm it’s possible that another plugin is interfering with the set up process. You could try disabling other plugins and attempting to re-install again to see if that works.

    The problem with disabling other plugins one by one is that the site looks broken. Not to mention that it’s very time consuming. So, to save time (ha!), I upgraded to the latest version of WP.

    Alas, autosyncing is still showing up as “unconfigured”.

    In spite of the fact that I believe my Disqus account seems to be configured, this is what I see after selecting the “enable auto syncing” tab in the wp-admin area of the Disqus Plugin:

    Auto syncing: Not Configured
    Error enabling syncing: Verification request failed: 2018-05-31 5:51 pm

    I have got manual sync’ing to work but it could prove to be a little unwieldy to have to remember to do it. Because autosyncing was working before the latest plugin update, and because manual sync’ing is working, I’m afraid I’m disinclined to try to fix the autosyncing through trial and error by disabling plugins one by one.

    Thank you for your help, brevityness. Am I correct that autosyncing is working for you?

    If not, I’m not sure now who or how to ask about how to fix autosyncing, but as there is one other person who posted on the Disqus forum about autosyncing not working in her WP, I suspect it may be something that was done in the latest upgrade of Disqus itself.

    Augh!!!

    I have discovered that the missing comments in wp goes back much further than 24 May. I have also discovered that manual sync’ing doesn’t necessarily work. (For an April post that has 8 comments, only 4 appeared after the manual sync’ing.)

    I must apologize for taking up so much of your time, brevity.

    I just saw the following at https://help.disqus.com/troubleshooting/wordpress-troubleshooting-and-faq

    If Syncing is not working in version 3.x
    1. Check the webhook link here: https://YOURSITE.com/wp-json/disqus/v1/sync/webhook

    If that link is not returning anything or not loading, something is blocking outside sources like Disqus from making requests to your site.

    2. This may also be caused by a conflict with ones of your current plugins (often a security plugin). […] Specific conflicting themes that we’ve identified so far:

    Disable REST API
    iThemes Security

    I am running iThemes Security. I hesitate to mark this thread as resolved though. I will investigate with iThemes Security to find out the solution and report back if there is a solution.

    I tried disabling iThemes Security and switching to WordFence (my webhost will not allow me to run WP without a security plugin). Alas, the manual sync’ing still did not work.

    It’s with great regret that I have had to disable Disqus. So, even though the solution was not found, I’m marking this thread as “resolved”.

    Thank you again, brevityness, for all your replies.

    Mauricio

    (@mauriciogarofalo)

    How can I enable auto syncing? I have set up API in site configuration but when I click in Auto Syncing nothing happens:

    The Sync Tab says:
    Auto syncing: Not Configured
    Enable Auto Syncing (button) <- when I click this button nothing happens.

Viewing 8 replies - 16 through 23 (of 23 total)
  • The topic ‘Automatic Syncing no longer available’ is closed to new replies.