Support » Plugin: WP2Social Auto Publish » Automatic posting disabled for some users

  • Hello,
    my site has many users who write.
    The problem is that if someone changes in the posts “Enable auto publish post to my facebook account” in NO, this setting is also changed for some of the other users. And the publication on Facebook does not take place.
    How can I solve it?

    I am sure that some users have not changed the setting to NO, and suddenly they stop publishing even on facebook.

    Thanks

Viewing 12 replies - 1 through 12 (of 12 total)
  • If you don’t want to auto post on post edit action then please set Auto publish on editing posts/pages/custom post types to Disabled.
    And manually set Enable auto publish post to my facebook account to Yes when you want to auto post to Facebook.

    In the plugin settings it is always YES.
    In the posts I think that someone changes the settings on that post to NO, and this causes the change also in other users.
    I’m sure of this because some of my users didn’t know what that setting was, and some posts were posted on Facebook to set them to YES and others not because they were set to NO.
    How do I solve it?
    Isn’t there a log file to understand the problem?

    You can check the Logs section ,last 10 post logs are listed in it. (https://ps.w.org/facebook-auto-publish/assets/screenshot-4.png?rev=2124301)

    With that log I only see the posts published.
    It is possible to reset the settings for all users, I believe that someone changing the settings in NO has created a problem for many other users.
    At the moment some users (at the moment) are publishing on my site and some posts are published on facebook and others not, and I’m sure they don’t change the settings in NO for each post.

    I believe that there is a user who has changed the settings for a single post in NO for publication on facebook.
    And when this user logs in, he goes to change the settings for individual posts even for other users.

    At the moment my user, too, automatically has NO settings in his posts, and I have never changed anything.

    I noticed now.
    A user is posting 5-6 posts.
    Some are published on facebook because YES and others NO.
    One user, in an hour.

    If you set Auto publish on editing posts/pages/custom post types as ´┐╝Enabled then it will set the posting permission to YES on every post edit page.
    And it will auto post to Facebook if and only if the metabox settings are not overridden by the editor.
    Hope this helps.

    Yes, I understood that.

    But I believe that there is a bug for those who have many users with their site, between users who set NO in posts and others who, do not modifying anything, change the setting from YES to NO.

    The general settings ,log ,about page and smapsoluton’s authorization(if you are using Smapsolution’s app for facebook publishing) are only visible for users having access to Administration Screens.
    Any user who have access to edit your posts can change your post meta settings.
    The feature to prevent any particular user from auto posting(or setting access to selected users only) is available with the premium version.
    If you want customization in the free version you can contact our support desk.
    Hope this helps.
    Thank you.

    My users have the role of Author, nobody can administer the site, except me.
    I don’t want to prevent my users from posting on facebook.
    I want the exact opposite.
    Unfortunately, sometimes this does not happen.
    It all started when a user disabled the automatic publication for his posts (he was publishing old articles in the archive).
    After a few days we realized that other users also had automatic publishing disabled. Users who did not know how to change that setting before that day.

    If Auto publish on editing posts/pages/custom post types is Enabled and when editing a post ,the metabox posting permission is set to No by default,then it is an issue.
    If that settings is not modified manually then it will auto post on post edit.
    If this issue persists,please contact our support desk,we will check it for you.
    Hope this helps.

    I sent a message here
    https://xyzscripts.com/members/user/support
    Thanks

Viewing 12 replies - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.