WordPress.org

Support

Support » How-To and Troubleshooting » Automatic plugin upgrade not working – ftp problems

Automatic plugin upgrade not working – ftp problems

  • No matter what I try I simply cannot get the new automatic plugin upgrade to work. I keep getting this error after specifying ftp info:

    Error: There was an error connecting to the server, Please verify the settings are correct.

    The ftp account I specify takes me to the root of my WP installation and works perfectly with an ftp client like FileZilla…

    Can anyone help?

Viewing 15 replies - 1 through 15 (of 46 total)
  • Moderator Samuel Wood (Otto)

    @otto42

    WordPress.org Tech Dude

    The information you’re giving it is incorrect in some way. That info may work for you to connect to the server, but maybe not for it to connect to itself. Especially if the server doesn’t have DNS setup and working properly (surprisingly not uncommon).

    The short of it is that the automatic update stuff does not work on all systems and never will. WordPress cannot take every single server configuration into account.

    My server DNS working properly. Buy I have same problem like cjessing and same error. Can you help me please?
    How to correctly setup hostname when my blog is on subdomain. Is this example correct: http://ftp.domain.com/subdomain/
    The subdomain is root for WP.

    Moderator Samuel Wood (Otto)

    @otto42

    WordPress.org Tech Dude

    No, you don’t have to tell it the subdirectory, just the hostname. It will look for the right subdirectory.

    OK, I made special FTP account for subdirectory where WP is located. Bud answer from WP is “Unable to locate WordPress directory.”
    What now?

    Thanx

    Same for me. Works fine using a dedicated ftp program but I get the same error:
    Error: There was an error connecting to the server, Please verify the settings are correct.

    BigGauc, don’t use any rute on your new FTP account.

    Hope it works. Regards.

    either your ftp, username or password is incorrect. Try manually typing it in instead of pasting. You may have an extra space in there or something.

    I found that I needed to use my server name as the ftp host, not the normal ftp host name I use with an external ftp program.
    Example: Normally I use an ftp program to connect to myhost.com, but because the plugin is operating from within the server I need to use the name of the server (i.e. “testbox”) as the ftp host.

    I’m not quite good enough with setting up the server to understand exactly why it works. Perhaps I’ve done something that isn’t considered “correct”, but at least I figured out how to make the plugin work! 😉

    If you tried FTP over SSL and it didn’t work, that may be your problem. That feature will not deactivate even if you set it to “No” in the ftp config page. See this bug report:
    http://trac.wordpress.org/ticket/6986

    I’m going to resurrect this thread. I’ve got a gazillion WP 2.5.1 installs scattered all over the internet. I haven’t run into this problem until now. This is for a WP site that I host myself, a *.org, if that matters.

    None of the other sites on this server experience this problem, not even the other dot-org site. I went in and checked its settings and it’s what I normally put into those fields:

    1. the server name
    2. the user id (which is the hosting account user id)
    2. the FTP/hosting account password
    3. Use SSL? No

    I then decided to set up an FTP account just for that purpose. Checked the settings. Tried again. No dice.

    Why would this one site, on the same server as all the other properly functioning WP sites, NOT work? It’s giving that pink box error,

    Error: There was an error connecting to the server, Please verify the settings are correct.

    Okay, here’s more. After sitting there grinding away for like five minutes, I get this:

    Downloading update from http://downloads.wordpress.org/plugin/cforms.8.5.zip

    Unpacking the update

    Removing the old version of the plugin

    And then it spits out one of these for each file it’s trying to process. Do you think it could be an issue with the upgrade to this plugin specifically??

    Warning: ftp_pwd() [function.ftp-pwd]: Deleted /public_html/wp-content/plugins/cforms//images/fade-butt-lightblue.png in /home/gnoics/public_html/wp-admin/includes/class-wp-filesystem-ftpext.php on line 188

    Because I see something that doesn’t look right:
    …/plugins/cforms//images/…

    I’m still struggling… I tried following the advice from the bug report posted by CarltonBale and now I get:

    Downloading update from http://downloads.wordpress.org/plugin/akismet.zip

    Unpacking the update

    Warning: ftp_pwd() [function.ftp-pwd]: Opening BINARY mode data connection for /wp-content/upgrade/akismet/akismet/akismet.gif in /mounted-storage/home66a/sub001/sc35101-WCQM/[mysite]/wp-admin/includes/class-wp-filesystem-ftpext.php on line 188

    Could not copy file

    Then when I examine the upgrade dir I can see that the unpacked dirs are created with 755 and the files (it actually only tried to unpack akismet.gif) are 0 (zero) bytes. I have spoken with the nice people at Servage.net but they are out of ideas…

    I’m trying to automatically upgrade sociable and get a similar error to others in this thread. Mine says:
    Warning: ftp_pwd() [function.ftp-pwd]: Deleted /public_html/…/wp-content/upgrade/sociable/sociable/images/n4g.gif in /home/…/public_html/…/wp-admin/includes/class-wp-filesystem-ftpext.php on line 122

    This has happened to other sociable versions and other wordpress blogs on the same server. I don’t know whether it could be my new server though, because I did just move servers.

    If anyone has solved the problem, post it here please.

    norsted

    @norsted

    I’ve been struggling with this for a while, and i’ve pretty much given up finding a solution – i have the same problem:

    Warning: ftp_pwd() [function.ftp-pwd]: Transfer complete in /mounted-storage/home51b/xxxx/sc35444-DFZH/xxxxx/wp-admin/includes/class-wp-filesystem-ftpext.php on line 122
    
    Warning: ftp_pwd() [function.ftp-pwd]: CWD command successful in /mounted-storage/home51b/xxxxx/sc35444-DFZH/xxxxx/wp-admin/includes/class-wp-filesystem-ftpext.php on line 122
    
    Unable to locate WordPress Plugin directory.
    
    Installation Failed

    I’m starting to think it’s related to the host (servage.net) because i have another blog running on another server – which can be upgraded effortless!

    In short..HELP!

    johncolumbo

    @johncolumbo

    For anyone that may still be having this problem entering “localhost” into the ftp host box worked perfectly for me.

Viewing 15 replies - 1 through 15 (of 46 total)
  • The topic ‘Automatic plugin upgrade not working – ftp problems’ is closed to new replies.